Desktop crashes while using Topaz products


Last week, every time I used any Topaz product, my Windows desktop computer crashed.
It is continuing today…it crashes when I summon any Topaz enhancement (Photo AI, Sharpen,
Clarity…etc.) from Photoshop…it crashes when I summon any Topaz enhancement tool
stand alone.

This has been consistent for an entire week, and it’s wrecking my workflow.
All products are the latest from the Topaz site. I also shut down all programs running in the
background (Bridge, Spotify…etc.) to see if there was an overflow somewhere, and it continues
to crash.

I’m at the point where I may delete/re-install all elements to see if that helps.

I haven’t made any changes to my computer in the last two weeks.


Bill Hunt

As you haven’t even mentioned your PC specs or OS I can only offer general advice. Are there any log files available after the crash, if so upload here?

You need to check if there were any recent updates to your OS that may have caused the issue. Recent updates to PS etc.

And make sure your GPU drivers are up to date from the GPU manufacturers website … not Windows update or the PC manufacturers website.


Thanks for your quick response. I updated my driver on my NVIDIA card, tried
Topaz Photo AI, and my system crashed.

This is the event that was logged at the time of the crash…hope it’s helfpul…
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
to the user DESKTOP-D6MQ1A4\Bill SID (S-1-5-21-4005185952-4276602185-4293713986-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

You will need to raise a support request at the main website. Note that only DeNoise AI, Sharpen AI and Photo AI are supported … other applications such as Clarity are not supported.

It is very strange that this is happening, they should be able to help.

Thanks Don…I’ll try to remember to note here what comes of the

I just figured a problem I may have created. In an attempt to reduce the volume of
data on my root drive, I deleted a “restore” copy of the software, which might
account for the crashing.
I hate to go there, but I’m going to clear all Topaz software and reinstall fresh…

Wish me luck!

If you have done a restore that may be the issue, let us know here if it is … and … good luck!

OK, I’m cautiously optimistic. I noticed the CPU fan was spinning up when the crashes occurred, and decided to look into that symptom. During the research, I considered the GPU and found out that many of the things that were happening occur when a GPU goes bad.
I loaded the latest driver, but the problem still persisted…then I decided to check the connections. They weren’t loose, but after I re-seated them, the problem seems to have gone…
I figure the load presented to the GPU by the apps (along with the bad connections) just stressed the GPU beyond its capabilities, and it caused the blackout.
Anyway, you can close this thread as solved, and if anything happens in the future, I’ll give a hollar.

Thanks for the help!

1 Like