DeNoise v2 Install ... No Uninstaller in Folder

Don I’m having some difficulties following the instructions. I have DeNoise AI installed on my computer, and can use it by clicking the Green “D” Icon on my desktop, but I can’t find a way to uninstall it. It doesn’t show up when I go to my Control Panel which is where I normally go to uninstall a program. I have the DeNoise AI BETA version 2.0.0.15b showing there, but not DeNoise AI.

Hi Terry, try going to where DeNoise is installed, I also assume the beta is not still installed, you can do that by right clicking on the Icon, select properties and then click Open File Location.

In that folder there should be a Uninstall.exe file, run that.

After doing that I would then delete the Beta version, either by trying the uninstall from the Control Panel, or if that is no longer available do the same and run the uninstall in the beta directory. Failing that simply delete the Beta directory, it doesn’t make a difference. And then delete the Local AppData folder for the Beta version.

After that use the instructions after you reinstall.

Don I’ve been working on trying to follow your instructions here for a couple of hours. When I right click on the Topaz DeNoise AI icon, and selected properties and clicked “Open file Location”, it took me to program files - Topaz Labs, and there is an uninstall “Topaz DeNoise AI” file there as you can see in this snip.
%20Denoise%20Uninstall
When I double click on it this window opens.

%20shortcut%20message

I clicked on “FIx it” and this window opened up
do%20you%20want%20to%20uninstall%20studio%202

I chose to click “no”.

DeNoise BETA doesn’t show up anyplace so it appears to be uninstalled. I don’t have an Icon for it, and it doesn’t show up in my Control Panel.

By saying fix it the system assigned the link to the uninstaller in Studio.

Firstly I would try to install DeNoise v2 into the same folder as you currently have it installed to. That should delete the current install and install v2.

Do that first and if it doesn’t allow you to uninstall then, I can give you instructions on how to manually uninstall.

Hi Don, Re-installation seemed to go through just fine, but I’m actually not certain where it was installed to. I assumed it would go into my programs folder along with all the other topaz software, but it isn’t in that folder.

I did a computer search for Topaz DeNoise AI and got a list of 4 folders. I checked the pathways for each of the folders and the second one in the snip below has a folder that was created today.
topaz%20Denoise%20folders

I wasn’t given an option to choose where it should be installed when I did it a couple hours ago. I assumed it would go into the folder with all my other Topaz products, but it didn’t.

Here is where the program data went.
folder%20created%20today

It seems you have actually installed the product to the Program Data folder previously. Delete that folder and reinstall if you cannot uninstall first from the control panel/settings.

The default Programs install to C:\Program Files\Topaz Data LLC and the Program Data installs to C:\ProgramData\Topaz Labs LLC

This is the default installation the setup wants me to use. Is this correct?! Instead of just to Topaz Labs LLC as you wrote, it is creating another folder where it ends up called Topaz DeNoise AI.

installation%20default

That is right for the resources, what about the program? It will be on the panel before, press Back and check that it installs to C:\Program Files\Topaz Labs LLC\Topaz DeNoise AI

That was my question also. I thought something had changed, that somehow the program files would magically find their way to where they were supposed to go. It never shows up. Here are the installation steps I’m given. Once I press that last button the installation automatically starts up.
Step%201
Step%202
Step%203
Step%204
Step%205

It seems like it now installs to the last install directory and doesn’t give an option to change. Note that if you run the installer it should say it will uninstall from that directory and then you should be offered the option to change the directory when the installer starts after the uninstall.

If that doesn’t happen to force the choice of folder option in the install you will need to go to the registry, search for RegEdt32 and run the app, then search for the following string in the registry:

Computer\HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz DeNoise AI

Delete that key and re-run the installer. Note that you will have to sign in again also.

Thank you AiDon. I have a new appreciation and empathy now for other BETA testers who have had difficulties with installations. This is something I’ve never experienced with Topaz software. I also have a great deal of appreciation for you and the others at Topaz who have considerable patience and have always provided me with excellent assistance when needed. Deletion of the Registry keys for DeNoise AI and DeNoise BETA was the answer I needed. I simply had no idea why steps I expected during installation were not happening the way I knew they were supposed to.

1 Like

I am now in a mess, after I uninstalled DeNoise AI and installed the new version I changed the folder from Topaz Labs LLC to Topaz when Studio 1 is. When I checked the filters in Studio 2 DeNoise is grayed out.
I went to uninstall DeNoise AI but it is not listed in Apps and Features. How do I uninstall DeNoise so I can reinstall ?

Hi Raquel, I had the same problem. If you check AI Don’s answer to my request a few posts above, you will see how to handle it. You need to go into the registry. Delete a couple of things and then reinstall. If you have questions just ask.

I found two entries DeNoise AI and DeNoise Beta. If I delete both entries will I still have an issue with uninstalling DeNoise. Its not listed in Apps and Features so at this time I can’t remove it. reg

Sorry I’m so late Raquel, I just saw this. I’m unable to give you any promises but I did delete both AI and AI BETA and nothing bad has happened that I’ve noticed. When I reinstalled after downloading from Topaz I did get an Uninstall file. I found it by right clicking on the desktop icon for DeNoise going to Properties and then clicking on “Open File Location.” It should be just under the Topaz DeNoise AI.exe. I just attempted to use it and even though it is a shortcut it does work. Being a bit anxious, I did check first to see if it showed up as installed by going to “Control Panel” then to “Programs” and clicking on “Uninstall a program.” It now shows up on my list of installed programs and if necessary I could uninstall it from there.

The uninstall process has left me with no operating Topaz AI products. I made the choice to install Studio, Gigapixel, denoise and Sharpen on my super fast D: drive. Everything worked fine. After replacing the C: I uninstalled them ( from D: ) and tried to reinstall them on drive C: . NOW my machine is haunted, I have never had so many different issues. On one occasion attempting to uninstall Gigapixel, all the other programs stopped working. I am not afraid of digging around the operating system if I knew the tree. Latest issue the uninstall is lost in time and space.
I would just delete the entire Topaz LLC directory but that probably will not solve the issue. There are files scattered everywhere. Does anyone have a tree so I can manually uninstall and reinstall?

You don’t mention if you are using a Windows 10 machine but if you are then there is an uninstall program in each folder for the AI products. Program files > Topaz labs LLC > AI folder (Sharpen, Gigapixel, etc). If you can’t get your computer running right then you may need to just download the Windows 10 media to a USB drive and then format your C drive and reinstall Windows. Of course you will have to install all your programs again, which is a pain and can take a couple weeks.

If you have a recent backup that was working well, then do the Windows re-install and use the backup to bring back all the programs on the C drive.
https://support.microsoft.com/en-us/help/15088/windows-10-create-installation-media

After 2 weeks of busy work from Topaz CS, I think my solution is to stop using the products. Reformatting my hard drive to make a product work yikes!!! , like I have 2 days to reset up my drive. The Topaz downloaders is dumping all the files into a single directory , all the products are lumped together. I realize that they are moving to the Adobe model anyway. There would be no guarantee that the product would work after the major scramble looking for passwords, apps, and other complications needed to reformat the hard drive.
Yesterday I used the old installer and that installer created folders for each product ( well most ) so I got Studio, DeNoise and Gigapixel to run today. That will have to be enough.