DeNoise + Batch Processing, and Colour Profiles

I am attempting to batch process .jpg images shot in Adobe RGB. If I do a single image and specify the export as sRBG it works fine. But if I attempt to batch process the images it applies the Adobe RGB profile.

Hi, I will check on this but in the meantime change the Image format to JPG and specify the Color profile as sRGB as I show here, the other settings as you prefer:

image

@AiDon

No matter what I set the color profile to in a batch run, the exported JPG’s all have EXIF Color space as sRGB, which happens to be the source files color space.

It can be changed, see my reply above.

@AiDon

I’ve seen your post. If the source files are JPG, and the export is to be JPG, then one would maybe logically leave the Image Format as “Preserve source format”, however when you do that it seems that the export color profile will be the source color profile regardless of the setting of the Color profile setting.

So, with the Image format set to “Preserve source format”, if the source JPG’s are Adobe RGB and you want the exports to be say ProPhoto RGB, then you set the color profile to ProPhoto RGB. That results in the exports remaining as Adobe RGB.

In the same way if the source images are sRGB and you sets for the exported ones to be Adobe RGB, then they remain as sRGB.

And yes, with JPG source images, if I specifically set the Image Format to JPG, then the export color profile will be what I’ve set for color profile. Whilst that will get the result, it’s not intuitive. I certainly wouldn’t expect the two settings to be dependent like that.

I agree that it isn’t intuitive and I have reported it to the development team to get clarification, as well if you input RAW images it automatically doesn’t display Preserve source format so I believe that for batch Preserve source format shouldn’t be used for JPG images because of the quality issue. But, in any case the output color space should be changeable.

image

Please re-read my original post. That is exactly what I am doing. And I am telling you, it works fine when a single image is used, but as soon as I try to process a batch of images, it ignores the selected colour profile.

Do you have the output format set to JPG and not Preserve source format?

If you retain Preserve source format it will override the color profile on the output. So you need to set that option to JPG.