Denoise AI very slow to process

I’ve just downloaded, installed, and processed a couple of images through Denoise AI. As far as results go I’m impressed. How long it takes to process the image, however, is a lot less impressive. 3 min and 25 seconds once I go for final image and that’s not counting the “not quite as long” updates that you need to do during processing to see what you’ve got. I’ve got a 9 year old PC, Win 10, running an I7 with 16gigs RAM so I don’t think it’s my outfit. But if it is, I’d like to hear where I’m going wrong. Thanks

Can you open DeNoise and go to Help-> Graphics info, press the copy button then paste the info here please.

Also if you have dual GPUs make sure the application is using the high performance one. That can be set in the Windows settings for Graphics settings.

The key aspect is likely your GPU. That could be ascertained if you post your Graphics Info from the Help menu.

With an out-board GPU my AIDN processing times are nowhere near that long.

Don, I found the Graphics settings in Win settings and changed it to High Performance. It was on default. I have the Nvidia Card and then there is something on the motherboard, I believe, but only the Nvidia card shows up under System/Device Manager/Display Adapters. Making these change made the processing time a little more tolerable. It still takes 2min 20sec to load an image, 18sec to update, and another 2min 20sec to apply.

Application & Version: Topaz Denoise AI Version 1.3.2
Operating System: Windows 10 (10.0)
Graphics Hardware: GeForce GT 710/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 388.13
CPU RAM: 16374 MB
Video RAM: 2048 MB Total, 1088 MB In Use
Preview Limit: 2864 Pixels$

Although the size of your images certainly play a part, the performance issues you are observing are primarily due to the age/speed of your GPU.

See: https://gpu.userbenchmark.com/SpeedTest/77649/NVIDIA-GeForce-GT-710

GT%20710

Thanks for the info. I’ll check out the link.

OK, the other option you have is t set the preferences to CPU processing and OpenVINO as I have a 8 year old PC with a i7-2720QM CPU/8GB and a GTX-540M GPU. The GPU is very slow but CPU processing is fast. The settings, after selecting Advanced undef Preferences should look like this:

image

Try that and see if it makes a difference. Note that if you don’t get all the options just press Reset and the application will go through the benchmark process again and then, if it doesn’t select OpenVINO (CPU), you can change it yourself.

Sorry for the delayed response. I tried twice responding to Don’s email re his last post but kept getting a delayed delivery notice. So I’m posting the response here:

I already had the GPU/CPU checked in the manner your graphic indicated (default I guess) . Jgr00ms2 sent me a bench test of my graphics card and it’s pretty much at the bottom of the heap. I’m probably going to spring for a little more upscale unit: GT 1660 and hope that helps things on a bit. Thanks for your help.

1 Like

Don, I have now installed a much better graphics card but with no discernible improvement to Apply times when finished setting the Denoise AI sliders. I may need to change the settings you had me do (see screen image in your response) but I have forgotten how to get to that screen. Can’t find it in Photoshop Preferences not in Denoise AI menus. Please point me in the right direction. Thanks

Here’s the new Graphics info from Denoise:
Application & Version: Topaz Denoise AI Version 1.3.2

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce GTX 1660/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 432.00

CPU RAM: 16374 MB

Video RAM: 6144 MB Total, 5420 MB In Use

Preview Limit: 7734 Pixels

It looks like your GPU should be more than OK, just go to File-> Preferences, click on Advanced Preferences and then click Reset, then Close and it will benchmark your PC and select the best option for you:

image

Sorry to be dense but I don’t know where the particular File>Prefs>Advanced Prefs>Reset directory you’re referring to which will get me to the page in the image above. Where do I start?

In the File menu, it must be run as a standalone, choose Preferences, then you will see the panel above where you can click Advanced Preferences to get the rest of the panel, then click Reset then Close and it will benchmark when you save the image.

Success! I had forgotten I needed to open the stand alone version. Updating is now about 20sec and apply/save is just under 30sec. Thanks.

1 Like

@LFBrown Your GTX 1660 graphics card should be very good. However, your times still seem a bit slow but this depends on the size of the picture being processed. My Sony camera makes 16 Mpx RAW files. I have a AMD Radeon RX580 video card and I got the following times using Denoise AI in auto setting.
Denoise AI preview <3 Seconds
AI clear preview: <2 seconds
Denoise AI save (full picture process) 7 seconds (AIClear was faster)

Your 1660 card should be as fast as mine or maybe faster. Of course, if you are using a larger file then that might explain some difference.

Those are very much faster times than what I’m seeing. I have image files in both 16Mp and 24Mp, both from Nikon cameras. My other Topaz apps and Photoshop itself runs pretty much at the speeds you’re getting (now that I have the new card) so I’m mystified as to why Denoise is the problem child. You’d think if I had a setting wrong somewhere I’d be seeing slow speeds across the board. Perhaps it’s the age of my PC, about 9 yrs old.

Maybe. I have a Ryzen 5 2600X CPU (12 threads, boost to 4.2 Ghz) but I think the GPU does most of the work. You should have software for settings with the GPU card. Check and see if the GPU and GPU memory can run at full speed. For example my GPU memory can run up to 1950 MHz but goes to 300 MHz at idle. Also check the File > Preferences (use as a stand alone app) in Denoise AI to make sure memory use is on high.
Denoise%20AI%20pref

My preferences page is set up identically to your image. Good call on the graphics control panel, however, Denoise wasn’t even listed in the programs it was servicing and once I had it in I could set the performance to max. I only did a single image but Denoise AI previews are now about 5 seconds. Saves are now 23 seconds. I can live with those times. My machine is only 8 threads and I don’t know what the max speed is. I’d say yours has some muscle over mine. Thanks for the suggestions. They were very helpful,

1 Like

Sorry to resurrect this old thread - just wanted to express my thanks for the tips - got my process time down from 3:20 to 18 seconds per image. Same card as above :slight_smile:

1 Like