Denoise AI v2 misreporting (& using) the type of graphics card in use?

Hi all

I spotted this posting thread over at DP Review…and not sure I have seen similar here at Topaz community forum?

So very much a FWIW
https://www.dpreview.com/forums/thread/4464594

HTH ?

It isn’t a bug, the GPU needs to be allocated in the system to DeNoise AI. The system default is the integrated graphics for Windows but you can allocate using the NVIDIA Control Panel, or easier using the Graphics Settings in the control panel … for example:

image

Thanks Don for the insight :slight_smile:

As I only have the nVidia GPU card in the PCI slot I obviously see things differently, so as your reply has relevance I will post a link to this thread @ DPR.

Hi Don
I’m one of the partissipants in that thread over there at DPR. (User “kohinoor”)
As stated there DenoiseAi does correctly identify my graphics card. But no matter which setting I choose in the advanced preferences ( enable discrete GPU on/off, OpenVino on/off) … the shown preview never matches the saved image. This is the case only with DenoiseAi but not with AiClear.
I have updated my GPU driver to latest version and I’m on Topaz Denoise latest version 2.0.
I and a number of other folks using this software would greatly appreciate if some technician from Topaz could have a look at the matter!
Thanks and Regards!

The first thing you need to do is to allocate your high performance GPU to DeNoise … as you correctly said you can do this using the NVIDIA control panel or, as an easier option, Windows 10 allows you to do this using Graphics Settings in the Settings.

Secondly , in the DeNoise Preferences panel, click on Advanced and then press Reset then DeNoise will do some performance testing and choose the best option for processing on your hardware.

Note also that it will run a little slower the first time after you press Reset. Note also that OpenVINO/CPU can be faster than many GPUs.

That is interesting. I’m on a couple Denoise AI threads at DPReview too.
I did the ‘reset’ and now that I look at the settings…
I see
“Enable discrete GPU” is OFF (it was using my NVidia card before)
and
“Enable Intel OpenVino” is ON

All that means is that the CPU/OpenVINO processing is faster than your NVIDIA card so that is the optimal processing for your PC :slight_smile:

oops.
I forgot to mention, my rendering times before the ‘reset’ were nearly 4 minutes per images and have now dropped to 30-40 seconds per image.

1 Like

After doing the advised allocation in the Nvidia control panel (via windows10) and performing a reset in the advanced graphics settings in DenoiseAi I now do get perfect matches of previews with final output (saved files).
Thanks for that!
However, I do notice a discrepancy with the settings the Reset defaults to. It sets discreteGPU to off and OpenVino to on. But I do get faster processing times with the opposite settings (GPUon/OVoff). So in my case the reset does not default to the fastest settings. This doesn’t bother me but I wanted to mention it.
Again, thanks for assistance!

2 Likes