Denoise AI stalls during photoshop action

I’m trying to create an action in photoshop that sends an image to Denoise AI (2.2.7) creates a setting in Denoise and then saves it back to photoshop. While recording the initial action steps it opens in Denoise, I make my adjustments and when I choose to accept it processes the image and sends it back to photoshop. All good during recording. When I go to apply the recorded action to another image Denoise will not close and send back to photoshop. It applies the settings but does not accept changes unless I click on accept. Any ideas are welcomed…

Maybe someone else can help you here but I believe that a PS action only works within Photoshop and it cannot address settings in an external application.

Yes, this is indeed a problem. The developers have not bothered to fully integrate the plugin into Photoshop. For batch conversion, I use third-party programs (clickermann) or a script to automatically click on the “accept” button. It’s terrible, but I can’t find any other way out. We are waiting for the developers to solve this problem.

DeNoise AI has its own batch interface, why would you do that.

PS actions don’t work outside of PS as it is a plugin where the app is not part of PS.

Interesting thing also is it worked fine with DeNoise 6. I intigrate the Denoise into an action that includes my watermarking and resizing. It applies watermark, resize and Denoise in one action. DeNoise AI is the version now that does not seem to work in an action. Will probably have to use the batch maybe.

Actually I have used actions to perform adjustments in plugin programs like On1 Effects and Topaz Denoise 6. I think the trick is as you are recording your action you need to open the plugins from the Filter menu and not open the programs separately as stand alone. Actually works very well can get a lot done with one action.

That doesn’t seem to work with the AI plugins as it doesn’t get past the invocation from the filter menu, i.e. external mouse clicks or slider movements are not recorded.