Denoise AI failing to launch (Windows 11 / Geforce / second monitor)

Hello to you all tech savvy friends! I have a strange issue, that you might be able to help me with.

I have the latest version of LR/PS/ACR and the latest Denoise AI version. I bought a new laptop (running on windows 11) and when I open denoise AI only from my laptop (as a LR/PS plugin or standalone), everything seems to function properly. The minute I connect a second monitor, Denoise only launches once and after exiting, it does not launch again either as a plugin or standalone. Even after disconnecting the secondary monitor / rebooting etc, Denoise will not work again.

I am not tech savvy, but I can only guess that there must be some sort of clash with Denoise and Geforce (maybe that regards the second monitor?) and after the initial clash, a registry entry remains, so even when I disconnect the second monitor, the program is still not working. When I delete the last two registries (ie x and y) in Computer\HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz DeNoise AI\appMain, then everything works for some time and then the problem appears again.

I have tried this with a couple of monitors and different HDMI cables and the problem persists. I have the latest Nvidia and AMD Randeon Graphics drivers. I have also used beta 3.7.1 but again with no luck. I have uninstalled, deleted all registry files, LR external editor preset, reinstalled, again nothing.

I have contacted support, who came back to me to request logs and system info (Lingyu Kong). Ever since I have not heard back from him though.

Can anyone please help me as I am pretty desperate and have tired everything I could think of. It’s a shame to have updated my hardware and all my software and not being able to do my work :frowning:

Application & Version: Topaz DeNoise AI Version 3.7.0
Operating System: Windows 11 Version 2009
Graphics Hardware: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 516.94
CPU RAM: 32104 MB
Video RAM: 6144 MB
Preview Limit: 8000 Pixels

Windows ver: 2022-08 Cumulative Update for Windows 11 for x64-based Systems (KB5016629)

Update for anyone facing the same issue. Topaz AI actually fails to reopen, IF the program is exited when developed in the SECONDARY monitor.

The only fix I managed to find is to exit the program ONLY from my main / laptop’s monitor. In case it is used as a plugin, the same applies - make sure you save your image whilst in your primary monitor. This is the only way to have the program open again. In case you have exited from your secondary monitor and the program fails to open (ie you get a white screen), then go in your registry file (Computer\HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz DeNoise AI\appMain) and delete the VALUE X registry completely. It will then reopen in your primary monitor and take the correct x value automatically. What a stupid thing to do, but that’s the only way I managed to get the program running.

This must be a bug of Topaz and it only happens with their products. Support could not help and they only told me that they will inform the developers about it, as to find a fix in their next update. Imagine if I didn’t do all that research to understand what is going on and how to have an interim fix. I would have paid for a product that is simply not working…