DeNoise AI blank screen after update

I updated DeNoise AI from 2.2.11 to 2.2.12, and now just have a blank black screen when DeNoise opens. I get the Topaz DeNoise bar at the top but just a black screen below. I tried uninstalling, and reinstalling, tried the online update and the full update, but same thing happens. I tried opening just the program itself, and opening from inside TS2, same thing. Just nothing. Help, please. Thank you.

Please check that your GPU drivers are up to date and, if you have dual GPUs, that the high performance GPU is assigned to DeNoise via the Graphics Settings in the Windows Settings.

Thank you. I’ll check the driver update. Not sure if I have dual GPUs, as I’m not sure what you mean. I do have the Intel Graphics Card and then the dedicated NVIDIA that I use for all photo editing, if that’s what you’re referring to. If that’s what you mean, then if I understand correctly from Dell, whatever is plugged in to the dedicated card on the back of my computer, is what Topaz is running off of. (Sorry, not good with all the techie stuff, obviously).

Found the Graphics Settings in Windows. (woohoo). It says there are no apps listed to customize, and to choose an app. I’m guessing that I should go to C>program files>Topaz Labs>Denoise. When I get there, I’m given a choice of PS Plugins and PS Plugins_x64. If I click on either of those, message says “no files match your search”. I’m sure I’m not doing something correctly.

Try C:\Program Files\Topaz Labs LLC\Topaz DeNoise AI and there should be a .exe there called “Topaz DeNoise AI.exe” add that to the Graphics settings and choose High-performance GPU.

Thank you. I never would’ve gotten that far. I did make that setting change, but still nothing. The program opens, I get the DeNoise “splash” screen for a second then just a black screen with the DeNoise bar at the top.

Hi, I suspect that you will need your GPU model i.e. GTF ??? go to the NVIDIA website and download the latest driver and install that. If you want to know what the existing version is go to the Driver details in the properties of the NVIDIA GPU in the preferences and it will be the last 5 digits of the driver version.

image

I’ve updated my graphics driver but still just getting a black screen as before.

That is strange, what is the dedicated NVIDIA GPU you have? Please give the Model, dedicated vRAM and the driver version. You can find it if you run DxDiag from the search box and click on the Display 2 panel and you should see something like this:

image

Just post the screenshot here. Also what are the pixel dimensions of the image you are trying to process?

I am so sorry but this is what I got when I tried to screenshot the DiagDx report. Obviously, I’m not doing something right here. Hope you can see the info you need this way.

DeNoise won’t open at all for anything. Whether I try importing ANY photo at all from PS or LR, or if I just go directly to DeNoise to open as a stand alone, I get the same thing…Splash screen pops up, then a black window with the DeNoise bar at the top.


Display Devices

       Card name: NVIDIA GeForce GTX 970
    Manufacturer: NVIDIA
       Chip type: GeForce GTX 970
        DAC type: Integrated RAMDAC
     Device Type: Full Device (POST)
      Device Key: Enum\PCI\VEN_10DE&DEV_13C2&SUBSYS_85081043&REV_A1
   Device Status: 0180200A [DN_DRIVER_LOADED|DN_STARTED|DN_DISABLEABLE|DN_NT_ENUMERATOR|DN_NT_DRIVER] 

Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 15257 MB
Dedicated Memory: 4043 MB
Shared Memory: 11213 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
HDR Support: Not Supported
Display Topology: Internal
Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
Color Primaries: Red(0.637695,0.330078), Green(0.311523,0.623047), Blue(0.150391,0.067383), White Point(0.313477,0.329102)
Display Luminance: Min Luminance = 0.500000, Max Luminance = 270.000000, MaxFullFrameLuminance = 270.000000
Monitor Name: Generic PnP Monitor
Monitor Model: 2353
Monitor Id: AOC2353
Native Mode: 1920 x 1080§ (60.000Hz)
Output Type: DVI
Monitor Capabilities: HDR Not Supported
Display Pixel Format: DISPLAYCONFIG_PIXELFORMAT_32BPP
Advanced Color: Not Supported
Driver Name: C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_feed726c6560f7a7\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_feed726c6560f7a7\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_feed726c6560f7a7\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_feed726c6560f7a7\nvldumdx.dll
Driver File Version: 27.21.0014.5671 (English)
Driver Version: 27.21.14.5671
DDI Version: 12
Feature Levels: 12_1,12_0,11_1,11_0,10_1,10_0,9_3,9_2,9_1
Driver Model: WDDM 2.6
Graphics Preemption: DMA
Compute Preemption: DMA
Miracast: Not Supported by Graphics driver
Detachable GPU: No
Hybrid Graphics GPU: Not Supported
Power P-states: Not Supported
Virtualization: Paravirtualization
Block List: No Blocks
Catalog Attributes: Universal:False Declarative:True
Driver Attributes: Final Retail
Driver Date/Size: 9/29/2020 7:00:00 PM, 1039376 bytes

I thing the time has come for you to open a support request at the main website as I cannot see why the application shouldn’t open unless it may have been installed without administrator access.

I’ll submit a ticket. Thank you for your help.

1 Like