Denoise AI 3.7.1

Installed denoise ai 3.7.1 today. Ran some files through it. When i went to import them into Lightroom I received an error message that the file could not be previewed, and it would not import. Rolled back to 3.7.0 and worked with no issue.

Please, please provide details of your environment, image types processed from LR, LR version, and image types output by DeNoise ai if you aren’t using as a external editor.

What you have posted means absolutely nothing.

I get that you need details to help troubleshoot, but it doesn’t mean absolutely nothing…it means there’s an issue with that release. Snarky comments like that is why Topaz has a crappy reputation for support. Might be time to ditch Topaz for DeepPrime XD.

Win10 PRo Ver. 21H2
OS Build 19044.2604
64 bit x64 based processor

Topaz Denoise AI Ver. 3.7.1

Adobe Lightroom Classic Ver. 12.2 release Camera Raw 15.2


  1. Offload jpg files from card to pc
  2. Move files from folder to Denoise - Used as external editor
  3. Run Denoise and output files in jpg
  4. Attempt to ingest files into Lightroom. Lightroom cannot create a file preview nor import the files when I try to import them.

Revert back to Denoise 3.7.0 and no issues.

I am having the same issue. I am now attempting to find out how to roll back. Any guidance would be appreciated.

Go to the Product Releases section for DeNoise on this Forum and download the version you want from it’s thread.

Rolling back to 3.7.0 worked for me. I downloaded both the online and full installers, but ran the full installer.

Found it. Downloaded and successfully installed 3.7.0 and it now functions as before. Thanks a ton!

I meant 3.6.0…which I’m guessing is what you meant as well. Glad it’s working for you.

You posted a link to 3.7.0

That I did. Apparently I’m losing my mind.