Denoise AI 2 crashes on my large images

Hi,
I finally updated my DeNoise AI install to version 2.

I have just spent an hour trying to get it to process one of my Canon 5DSR images as a plug in in Photoshop CS6. I tried every combinations of GPU or openVINO settings. Each time the plug in processed all the way to 100% and then the plugin crashed leaving Photoshop running and the image unprocessed.

Finally, I reduced the image size from the original 8688x5792 to 3000x2000 pixels and the plug in ran successfully, which suggests that the issue is related to the file size.

It is very disappointing to think that the latest upgrade has introduced this problem.

I hope this gets fixed.

Just did another test.

With a 16bit .TIFF from a Canon 5DSR, Topaz Denoise AI v2 fails in free standing mode as well.

As a last, test I ran Topaz DeNoise v1.3.3 plugin on the same file and it works fine.

It had run well in the past, and it still does.

V2 is useless for me until this gets fixed.

Please go to Help-> Graphics info and press Copy then post the information here.

Do you have more than one GPU on your PC?

Don, the OP’s test shows:

  1. v2 crashes with file-size > X
  2. v2 does not crash with file-size < Y
  3. v1 does not crash with file-size X or Y

Based on that, it is very unlikely to be HW related.

To the OP, I would:

a) turn file-logging on: [Help->File-logging] (debug dump/trace logs will be created while toggled)
b) run v2 with File-X and let it crash (important to have crash reproduced)
c) open a support ticket (support@topazlabs) and get a DropBox link to upload your file-X.
d) tell them that you have crash-dump files for them to analyze. They can tell you what dir the files will have been output/written to
e) upload the crash-dump files to the DropBox link
f) wait for the devs to analyze the trace and see where the app is crashing

This sounds like a memory allocation (ie SW) defect introduced in v2.

Thank you for taking the time to make a suggestion.

I will log a crash and open a ticket tomorrow.

Well with the change of the install location many people forgot to update the allocation of the high performance GPU to the application.

In my case I have 5DsR images and RAW, TIF as standalone input have no issues as do calling from CS6 and Affinity Photo.

And I don’t see any memory issues at the moment for both standalone, plugin or batch processes.

So, the change of the install location dir caused the preferred GPU setting to go back to the default setting? There was no avoidable way to prevent that? Could the settings not have been automatically copied from the old location? That’s a bad burn.

In any event, if v1 does not crash with whatever the selected GPU/memory is set to then v2 should not crash either, correct?

Yes that is so because the GPU settings on Windows, in these Apps cases, are set either using the respective Control Panels for the GPU manufacturers or through the Win 10 Graphics settings. I guess this is a limitation of the Qt interface because of the cross platform portability.

In any case we don’t even know the posters OS, RAM, GPU etc, in many cases the updates may be getting closer and closer to requiring the minimum technical requirements but this case is a little strange because the standalone version is crashing also, if it was just PS I would recommend reducing the resources available to PS as it pre-allocates those on start up.

In any case your recommendation will work but it may take longer to process as if it is a simple resource issue it can be readily solved.

Yes, the OP should double-check and make sure no inadvertent changes were made to the GPU selection. As you mentioned, Help->Graphics-Info is the quickest way to verify that.

1 Like

Here is the Graphics Info from v2:

Application & Version: Topaz DeNoise AI Version 2.1.6

Operating System: Windows 7 SP 1 (6.1)

Graphics Hardware: Intel® HD Graphics 4600

OpenGL Driver: 3.3.0 - Build 9.18.10.3165

CPU RAM: 16140 MB

Video RAM: 1500 MB

Preview Limit: 3135 Pixels

… as mentioned

It doesn’t matter if I Enable Discrete GPU or not, it doesn’t matter if I unselect Enable Discrete GPU and then select or deselect OpenVINO.

1 Like

Here you can see that the process makes it to 100%. This is what it looks like just before it fails.

Here is the V1 info. V1 works without crashing.

Application & Version: Topaz Denoise AI Version 1.3.3

Operating System: Windows 7 SP 1 (6.1)

Graphics Hardware: Intel® HD Graphics 4600

OpenGL Driver: 3.3.0 - Build 9.18.10.3165

CPU RAM: 16140 MB

Video RAM: 1500 MB Total, 1024 MB In Use

Preview Limit: 3135 Pixels

… as mentioned above, this morning I had run the v2 Denoise AI process successfully on an image with reduced pixel dimensions of 3000x2000.

This evening I attempted the process on the same image resized from its original 8688x5792 dimensions to 6000x4000 pixels.

The v2 Denoise AI process ran successfully with both the GPU selected, and the GPU not selected while openVINO was selected.

I am going to do a log dump in the morning, submit a ticket, and stop wasting any more time.

Thank you.

2 Likes

The Log files and Graphics Info have been forwarded to support.

2 Likes

Good news!

Although the official support response was a diagnosis that my computer did not meet the minimum requirements to run Denoise AI v2, someone at Topaz fixed the actual problem and the latest version 2.2.1 runs great on my machine.

2 Likes

Great! Did they make a change on your system? Or a change to the application?

BTW, even when if a system doesn’t meet the min requirements, the app should NOT crash. That’s a programming defect anyway you slice it ie an ungraceful catch of an error condition.

No change to my system. Specs are posted above.

The application seems to have been improved.

I just ran a test; In addition to being able to run the Denoise version 2.2.1 process on my native resolution Canon 5DSR files, which are 8688 x 5792 pixels, my system can also process images that I have doubled in size using Gigapixel. In other words, version 2.1.6 could not, on my system, process a image that was 8,688 x 5,792 pixels, but version 2.2.1 can process an image that is 16,602 x 11,122 pixels. That’s quite an improvement.

FWIW, version 1 could and does run the process on the same 16,602 x 11,122 pixel files as well.

1 Like