Crash & Reboot: Tapaz Video AI 3.1.1 on macOS 13.2

For a day or so I had no problems converting some Blu-Ray video rips in Video AI using the Artemis Denoise/Sharpen model. Over the last two days my computer screen eventually will display pink boxes and lines and the computer will restart entirely. Sometimes it is within a few minutes of starting the export job, sometimes after 40 minutes. The only change that I’m aware of is applying the latest update to Video AI.

I’m on an M1 Ultra 128GB Mac Studio and run a very lean system overall. When I pull up the app and throw one of the videos in there I can preview it as many times as I want with different settings, but eventually once I start exporting, KABOOM!

Here’s the app running a preview of one of the videos I’ve been trying to convert. It isn’t just this video, it is any video I try at the moment.

This is the export command for what I’m trying to do:

ffmpeg "-hide_banner" "-nostdin" "-y" "-nostats" "-i" "/Users/brockgs/Movies/Blu Ray Discs/Robotech P1 D5_t02.mkv" "-sws_flags" "spline+accurate_rnd+full_chroma_int" "-color_trc" "2" "-colorspace" "2" "-color_primaries" "2" "-filter_complex" "tvai_up=model=alq-13:scale=0:w=1920:h=1080:device=-2:vram=0.4:instances=0,scale=w=1920:h=1080:flags=lanczos:threads=0" "-c:v" "hevc_videotoolbox" "-profile:v" "main10" "-tag:v" "hvc1" "-pix_fmt" "p010le" "-allow_sw" "1" "-b:v" "16M" "-map_metadata" "0" "-movflags" "frag_keyframe+empty_moov+delay_moov+use_metadata_tags+write_colr " "-map_metadata:s:v" "0:s:v" "-map_metadata:s:a" "0:s:a" "-c:a" "copy" "-metadata" "videoai=Enhanced using alq-13. Changed resolution to 1920x1080" "/Users/brockgs/Movies/Blu Ray Discs/Robotech P1 D5_t02_alq13_temp.mkv"

Here’s the log from the last conversion that ended up crashing my whole system. I clipped out 75% of the log from the middle of the file because it was way too big to upload here, but I left the beginning and the end in. I’m happy to email the Support logs to someone in technical support I just couldn’t find any way to contact technical support anymore directly.

2023-01-27-11-32-29-Main.tzlog (1.6 MB)


I tried rebooting into Safe Mode with ALL usb and Thunderbolt accessories unplugged. The only connected devices were my monitor (ok, that uses a Thunderbolt connection), and my keyboard and mouse (bluetooth).

Still experienced crashes that cause my machine to kernel panic and reboot. One time only it crashed but didn’t cause my machine to reboot.

What I’m trying now:

I just downloaded Video AI 3.1.0. So far I haven’t experienced any crashes, but it’s only been running for around 45 minutes at this point. I’m cautiously optimistic thought because Video AI 3.1.1 would usually crash within 15 to 20 minutes of processing. :crossed_fingers:

So, I’ve set it up with a large queue of videos to process and we’ll see if it can make it through the night.

Ok, well that didn’t last long. A few minutes after I posted the last reply, crash/reboot. :cry:

I suppose I’ll test the last 2.x version release in the morning and see if that will work.

Ok, have tested back to Topaz Video Enhance AI. All do the same thing. I’ve run Apple Diagnostics with no problems showing. I’ve uninstalled all the little esoteric little bits and bobs of background processes running from other apps, turned off Time Machine, quite every other app while running conversions and even transcoded the video I’m trying to process by putting it through ffmpeg myself to see if it was just some attribute of the original video container or audio/video streams in there that were causing issues. Nada. I’ve done tests/repairs on my hard drive with no errors showing up, reinstalled Topaz Video AI 3.1.1 several times and ensured that it has full disk privileges…etc.

I’m running out of things to try.

Is there a way to submit a request somewhere for technical support? I can’t seem to find an email address or technical support ticket submission page anywhere. Even in the CEO’s latest post about the January Video AI timeline his link to “contact us” just goes to the support site FAQ where I can’t find any information about how to actually contact anyone.

Help, anyone? :slight_smile:


Well, I believe I found the issue. After doing 5 hours of combined hardware diagnostics, software diagnostics and re-installations I found one thing that made all the difference.

I changed the export to use a temporary folder in my User directory instead of in the tmp directory as it is set to by default. I have no clue why this changed matters, but I have been able to process videos continuously without the app crashing or it causing my computer to reboot.

UPDATE: turns out the pink squares all over the screen right before crashing and rebooting returned. Sigh.

The pink artifacts and crash sound like a hardware issue to me. For example a GPU which is overheating or broken. I’d install some monitoring software to keep an eye on GPU temperatures.
The fix could be as easy as dusting out the PC or changing fan speed settings.
Next step if that doesn’t work is checking cooler mounting and thermal paste.
…worst case broken GPU: warranty.

1 Like

Thanks for the reply! :+1: You’re absolutely correct. I should have updated this thread, but forgot, so I’m glad you brought this up.

SOLUTION: Motherboard replacement at the Apple Store, thankfully under warranty.

For others who may experience things similar, @Propheticus is spot on. Pink artifacts on screen typically indicate hardware issues. I ran the hardware diagnostics multiple times on the whole computer, but they didn’t find anything wrong. I even ran third party hardware diagnostic stress tests and they didn’t find anything wrong. That had me thinking for sure it had to be a software issue, HOWEVER one of the biggest clues that is HAS to be a hardware issue is that there weren’t any kernel panic error messages or crash logs. When it is a hardware failure, many times it happens in a way that prevents the operating system from even being able to catch the error and quickly dump logs to disk.

SO, all in all, Topaz Video AI was doing everything right. Even though my machine only crashed hard like this when using Topaz Video AI, it wasn’t the problem, it was just exposing the issue by pushing the CPU, GPU, and Neural Engines hard which made the hardware fault show itself.