Copying and pasting mask to texture filter

I’m struggling to create a mask using the colour selector in the texture filter. Works fine with other filters, but not with texture; it’s just a grey square. So I created a mask using colour selector in another filter, and tried to copy to the texture filter. Again, it doesn’t work; just a grey square. I’m not having this problem with another other filters, just texture. What am I doing wrong?

Are you talking about Studio 2 and what OS?

Hi. It’s W10, and yes I’m using studio 2.

Yes there does seem to be a problem there, obviously you will need to raise a support request at the main website, but if you set the Texture to Background you can paste a mask and then switch to Foreground.

Thanks. I’ve tried your suggestion, and unfortunately that doesn’t work for me either. The colour selector works fine if the textile is set to background, but I simply can’t copy and paste that mask to foreground. The mask window just redisplays as grey, no matter what I do. I’ve raised a ticket, so hopefully this will be fixed. Thanks.