Command line not finding filters in 3.0.4

I can’t run 3.0.4 more than an hour without it crashing, so I’m attempting to use the CLI.

I have my Windows environment variables set per the documentation:

VEAI_MODEL_DATA_DIR            C:\ProgramData\Topaz Labs LLC\Topaz Video AI\models
VEAI_MODEL_DIR                 C:\ProgramData\Topaz Labs LLC\Topaz Video AI\models

When I run the command copied from the export :

ffmpeg "-hide_banner" "-nostdin" "-y" "-nostats" "-i" "C:/video_processing/DVD_IN/E1_t00.mkv" "-vsync" "0" "-avoid_negative_ts" "1" "-sws_flags" "spline+accurate_rnd+full_chroma_int" "-color_trc" "2" "-colorspace" "2" "-color_primaries" "2" "-filter_complex" "scale=w=768:h=576,setsar=1,bwdif=mode=1:parity=-1:deint=0,veai_up=model=dtv-4:scale=0:w=3840:h=2160:device=0:vram=0.9:instances=1,scale=w=3840:h=2160:flags=lanczos:threads=0:force_original_aspect_ratio=decrease,pad=3840:2160:-1:-1:color=black" "-c:v" "prores_ks" "-profile:v" "1" "-vendor" "apl0" "-bits_per_mb" "8000" "-pix_fmt" "yuv422p10le" "-map_metadata" "0" "-movflags" "frag_keyframe+empty_moov+delay_moov+use_metadata_tags+write_colr " "-map_metadata:s:v" "0:s:v" "-map_metadata:s:a" "0:s:a" "-c:a" "copy" "-metadata" "videoai=Deinterlaced and enhanced using dtv-4. Changed resolution to 3840x2160" "C:\video_processing\TVAI_export/"

I get the following:

[AVFilterGraph @ 000002e3ae926740] No such filter: 'veai_up'
Error initializing complex filters.
Invalid argument
PS C:\Program Files\Topaz Labs LLC\Topaz Video AI>

The file dtv-4.json is present in C:\ProgramData\Topaz Labs LLC\Topaz Video AI\models

Have you installed ffmpeg before? On my computer, if I type in ffmpeg in the command prompt, it lists out the details of my original install of ffmpeg. (No idea why, since I never ‘installed’ it. I just dragged and dropped it into a non-restricted folder.)
To get the TVAI version, I replace ‘ffmpeg’ with the full path to the TVAI version from the copied command.

1 Like

Yes, that’s a good idea to try. I have Handbrake installed, and maybe it’s using that executable.

Thanks, that fixed it. It must have been using Handbrakes ffmpeg. I’ll let it run overnight and see if it will complete without crashing.

Well it still crashed, about 1 hour into the processing. The CLI does not give a status of processing. It ought to at least have a frame counter, rate, and estimated run time.

Yes. You have to remove the -nostats from the command.

Thanks, that did it. Was able to run a seven hour job with no lock-ups. Now I should be able to automate the flow.