Colour artefacts when de-nterlacing

I am de-interlacing and upscaling some PAL 90’s TV shows and getting odd colours introduced (especially purple) that are not present in the original.
Granted the lighting is poor and there is often the odd (colour) reflection it is usually brief and not as noticeable as in the de-interlaced and upscaled version.
I have tried all models (Dione TV / DV, Proteus etc.) and all give similar results.

Any ideas on how to fix this?



1 Like

Try deinterlacing without upscaling and vice versa to see if the artifacts are from one or the other. You may need to do separate runs to deinterlace and upscale. Once you determine where the artifacts are being introduced, try adding some noise to that.

1 Like

Thanks for the tip, it is the de-interlace process that is introducing this.
I guess there is no way to de-interlace after upscaling in one pass?

Screenshot 2024-05-18 184625

If you run an enhancement on an interlaced video, the result will be an interlaced progressive video. TVAI has a setting for that, but it has fewer models available.

Try a deinterlace only run with different models and play with the Add Noise setting. With Proteus and Iris you can also try different settings on theReduce Noise, Dehalo and Anti-alias/Deblur sliders. I’d start by putting a number in Add Noise and then upping the Reduce Noise slider by an equivalent amount and see what happens. If you can get rid of the artifacts in the deinterlace run, then you can upscale in a second run.

I’ve tried all the models and they all introduce the artefacts.
The only thing that helps is to increase the framerate to 50fps, which reduces it though it is still there a little.
I guess there must be some of these artefacts in the source and the AI is increasing them, giving them more prominence when there are fewer frames…

Probably true, but you can often bury things like that with added noise before enhancement, which you then reduce during enhancement.

1st of all it is not deinterlacing that causes the color shift. Topaz doesn’t do any deinterlacing. the deinterlacing is done by ffmpeg Bwdif filter that VAI calls. what causes the color shift is the Topaz AI modules.

Try deinterlacing your videos in Hybrid 1st, then process the video in TVAI and see if it makes any difference.