Can't login Topaz Studio

Hi, i had a first version of Topaz studio and it was working fine, then an update came, i installed it, but i cannot login anymore.
Installation went fine, and the previous version was working, now i can’t get past the login screen.
Not sure if it is because my mac is too old.
Is there somewhere i can get the older version of Studio?

I have the same problem. When I try to log in, the little circle just keeps spinning. It was working fine until there was an upgrade from Apple and from Topaz within the past week. I’m running a MacBook Pro, early 2015, with a retina 13 inch display with 16 GB of memory, and OS 10.12.6. So far, nothing but silence from Topaz. Good luck to both of us!

I’m having the same problem both when I try to open Studio by itself and when I try to access by way of Lightroom plugin. I get a screen requiring me to login, but the login just keeps churning. I tried to delete Studio and reinstall, but the problem continues.

Same here also. Log in keeps spinning whether as stand-alone or thru Lightroom. Happened over this last week after mac High Sierra upgrade and a Studio update. I’ve uninstalled, re-installed Studio multiple times. 2 inquiries to Topaz have no response. Getting grumpy about a lack of customer attention.

Same issue here, just started a couple of days ago, after one of the many updates to Studio - I am running High Sierra, but it was working fine under High Sierra a week ago.

The same kind of problem over here … after using Topaz Studio from Photoshop once it will not open again. After restarting Photoshop again only one use is allowed. I’m using windows 10.

Does anyone read these posts, and more importantly the submitted help desk tickets ? I have one that is now over 22 days old, still open and no response at all. Not at all what I was used to from Topaz.

I also submitted a ticket about the login problem and so far, nada.

1 Like

I’m having same problem with my Mac mini… it was working fine all of certain i can’t pass the login screen! I even put a help desk ticket but then still no response.

FYI - I did receive a response from Topaz today on my ticket explaining they were swamped, at least there is movement now !

    • Sent from my iPhone 6

I am another one with the same problem. I submitted a ticket on October 11 and have not heard anything from them. Very frustrating because I like the program and really want to use it! The login screen wheel just keeps spinning. I’ve also reinstalled Studio, changed my password, etc. My computer is up to date and I’ve not changed anything on it.
Please, Topaz, help us!

If you’ve submitted a ticket, we will get to you. We’ve been actively investigating login issues, sync issues, and general use issues related to the Topaz Studio backend (server). We released a number of improvements in 1.4.4:

Thanks for the feedback - already was able to download and install 1.4.4, still see the login issue on my High Sierra iMac though.

i downloaded also the latest version and the login issue stil persists.
It was fine 2-3 versions previously.
i am on Macbook pro 2009 with Mavericks

After updating to 1.4.4, the login problem still persists - cannot get past the login screen, checking the help desk ticket status I saw mine were both marked as solved - Negative - they have not been resolved, so I added content reopening my ticket for the login problem, since I am unable to get into Studio I cannot confirm that the loss of EIF data was resolved either, but that ticket also was marked closed & resolved.

Imac, 32 GB ram, High Sierra.

Good news! I received a file to remove the Topaz Studio database file and allow a new install of Studio - afterwards login was successful from my High Sierra iMac - all seems well! I have responded to my help desk ticket that all looks good and marked the issue resolved for me. Just thought I would pas this news along!

1 Like

Great! I’ll go ahead and close your ticket, Donald :slight_smile:

For anyone else that’s running into this problem, we are asking you to please submit a request, so we can handle each case. We are investigating these problems, and want to get rid of them for good. The best way to do that is by using the tool we provide you, which asks you to provide the database file that you’re removing. This way, we can figure out why your specific situation occurred. We’ve already corrected many causes of failure to sync, failure to login, and failure to update presets. We are going to keep going until we’ve caught and handled as many errors in this process as possible. The goal is to have a hassle-free sync system. Unfortunately, that takes some refinement to get working just right.

Edit: I see you marked the ticket as solved when you replied. Thank you!

I’ve had ticket 129442 open since October 14th with no response. I would really like to get the log in issue resolved since I have a fair amount of work to do this week and was hoping to use Studio for some of it. Thank you.

I updated your request.

I’m having the same issue. A spinning wheel when logging in, that won’t allow me access to Topaz Studio