Can't Install Topaz Studio 2

I downloaded Studio 2 several days ago, but can not install it. When I click on the install “exe” file, I get the (normal) first launch screen, but it’s blank … can’t click “next” to continue.

Three days ago I submitted a ticket to Topaz “Support” (they call it Support), which has gone unanswered. Any ideas from the group would be appreciated. Windows 10 (64) system

This is what happens when the install process is begun:


As a side note, all other Topaz products have always installed and run flawlessly, as well as those of it’s competitor’s products.

I am not on Win 10. But use a Win PC.

Can you try deleting the installer .exe file you tried from your PC. Try downloading from scratch from the Topaz Downloads page & see if it was just a flukey initial download. You might even wanna Restart the PC for good measure. Then try the latter installer file.

Also, if you use Topaz products you are aware, don’t have any other host programs (Ps, Lr, Corel, Affinity, etc) open when you run the installer for Studio 2.

Good luck! :crossed_fingers:

Try grabbing the edge of the window and resizing it. I have seen this happen in the past on some windows machines.

1 Like

Bingo. Strange, but sometimes the simplest things are the most difficult. Have done thousands of installs over a period of over twenty years and this is the first time I’ve encountered this … was using an Install monitoring / snapshot software, which is what caused this. Dragged a corner of the window, voila!

1 Like

Thank you.

1 Like

Glad to hear that worked. It happened to me once, like to never figured it out myself :slight_smile:

Whoa, so weird! Thank goodness it didn’t require a full moon :new_moon_with_face: and an eye of newt!! :lizard: I’m gonna remember for future ref with my PC…