Can't get Topaz Studio search to work

I want to find a community effect in Topaz Studio using the search functionality, but I can’t figure out how to do it.

First I clicked on Explore / All at the left of my screen then entered the name of the desired effect in the search field and pressed return. Nothing happened so I clicked on the magnifying glass again and the name of the effect showed at the top, but there was no filtering of the search results.

In the screenshot below I repeated the steps entering the name (Soft Sunset Glow) of an effect that appears on page two of All. As you can see, there are no search results - just the normal list of all effects.

What am I doing wrong?

I don’t know that you are doing anything wrong. I’ve had similar issues with the search function. It seems to be hit or miss. I did get it to work this time on the preset you mentioned. I clicked on Explore/All then the magnifying glass, entered the preset name and hit enter. Sometimes you have to hit enter more than once.

Also, looks like you need to update to the next version too.

1 Like

Thanks, Kathy. I just updated to the newest version 1.3.3 and my results are the same - no matter how often I hit enter, the search functionality is not working.

1 Like

I’ve had the same issues. When members of the forum tell us their preset name and I type it in… sometimes I get them and other times… not?

Thanks @Kathy_9 for mentioning the Update to v.1.3.3… I didn’t see no announcement on the forum… or I must have missed it? I did just try searching a preset and it worked… this time.

1 Like

I’m glad that you sometimes get them. I’ve tried over and over and over and the search never works for me. I did dozens of test searches over several days for presets that I can find by scrolling just to make sure that the searched-for item really exists.

I finally submitted a support request, but I think it should actually be a bug report.


My problem appears to be solved. I had opened a support ticket because my Topaz plugins weren’t being validated and weren’t showing up in the Specialty section of Topaz Studio. The support team sent me a database utility to correct the Topaz files on my computer, and running the utility not only fixed my plugin problem, it appears to have also fixed my search problem. I can now search for effects in Topaz Studio! :smiley:


I am having the same problem with the very latest version - 1.4.4. Doing a search does nothing at all. How can I get that utility you spoke about?

I submitted a support ticket and was given a link to download the utility. It took over a week for support to reply to my request, so patience was needed. .

I was hoping that I wouldn’t have to submit another ticket, seeing as how it’s a known problem. Can’t you just give us the link here?

If Topaz had posted the link, my problem would have been solved much more quickly, so I hope they do post it. If you were asking me to post it, I must disappoint. I deleted the email and don’t have the link any more.

Ok, thanks. Guess I’ll have to submit a ticket …

Just want to mention here that I did submit a ticket and on the 2nd exchange of emails with Topaz I got a link to a similar database utility as mentioned above. It fixed the problems I was having (search not working, plus Clarity not appearing in the Specialty panel on the left). So Topaz appears to be wading their way thru the growing-pain bugs in Studio and making rapid fixes. Good service, for sure! :smile:


I submitted a ticket for this same issue yesterday, the response I received was “you have to hit enter after typing in your search”. For stinking real…like I wouldn’t think of that.
Of course I kindly responded that I had and nothing happens, I get another response that tells me to uninstall and reinstall. so I did that and now Topaz studio is locking up on me all the time (and of course it didn’t fix the search issue). Starting to really wonder…

I’m sorry this happened to you. Be sure to follow up with support in your support request.

1 Like