Can't Export from Lightroom to Studio

Well… this is frustrating.

I had some time this afternoon to spend futzing with Studio and all the plugins. Watched one of the recent videos about Detail in Studio… was all set to try a few things. Went back to Lightroom (the new “Classic CC” version - not sure about the new “CC in the Cloud” version yet). And… full stop.

I cannot get get files from Lightroom to open in Studio. Despite countless attempts (each of which created a new file, since my setting is “open new file with Lightroom adjustments”), Studio seems unwilling to import the file from Lightroom. All I get is this:

…over and over again. I tried exporting the file from Lightroom to my desktop and opening it from there, but that just opens the RAW file (Nikon NEF), with none of the adjustments from Lightroom (since they are in the XML sidecar file).

These are the settings I’m using in Lightroom:

I tried rebooting my (Mac) computer, didn’t make any difference. Still stuck.

Lightroom is still the center of my workflow. I’d like to start using Studio, but it’s no good to me if I can’t directly import the files.

So, anybody got a clue?



I’m using an iMac and I use NEF and RW2 files. I’m also using LR Classic (LR CC is very sparse functionality-wise).

So I tried to repeat your problem but failed. Everything worked as it should.

It’s a mystery. Sorry I can’t help, hope someone else can shed some light on what is wrong.

I may have isolated the problem.

Since migrating all my work from an iMac to a 2017 MacBook Pro (and external 27" 4K display), most of my files are in “Network Attached Storage” – two multi-terabyte hard drives that are attached to a Mac Mini that the MBP reaches via WiFi. This year’s work I have stored directly on the MBP’s SSD.

I tried a couple of different configurations, starting with .JPG files stored directly on the MBP. That worked fine. Then I tried an .ORF (I shoot Olympus now, ditched the anvils several years ago), also locally stored, that also worked fine.

But when I went back to the files stored via the Mini… THAT’s when they wouldn’t load. Not .NEF, not .ORF, not .JPG. So that seems to be the issue. Which is a bummer because that’s where 90% of my stuff is stored (like the Day Farm photo I was working on yesterday).

FWIW, all the other programs I use – Lightroom, Photoshop, the MacPhun products (Luminar, Aurora), and even the Topaz modules (Clarity, Detail, Adjust, etc.) work fine with the remotely-stored files. I only seem to have that issue when loading from Lightroom into Studio.

But here’s another interesting wrinkle: if I load the file from Lightroom into Photoshop first, then launch Studio from Photoshop, the same file that would not open from Lightroom into Studio opens fine from Photoshop. What’s up with that??

Does that help? I hope there’s a reason/solution, because I could get used to Studio now that I understand how it works, but I have to be able to load all my files from Lightroom,.



When I open Studio from Lightroom I can work on the image and save it as a Tif but it does not return the image to Lightroom. The image is saved in the file which I requested but I cannot see it in Lightroom. If I open Bridge then I can see it but not from Lightroom.

Possibly Synchronizing the folder within Lightroom will import the image.

Yes it does but it should be returned to Lightroom as it started there.

It seems to me that AngieD is citing a different issue from the one I’m trying to sort out, so I’m not sure to whom techman/Larry’s reply is directed.

FWIW, my folders are “sync’d” to Lightroom, though I’m not sure that’s the right terminology. I do have to link the folders to Lightroom when I go looking for one of the NAS drives, but once they’re found/attached, everything works as though the drives were hardwired. So I don’t know why I can’t export those files into Studio.


Different problem but same interface - Lightroom & Studio - which may or may not be that Lightroom is not playing well with Studio.

Gotcha… good point. Hope the good folk at Topaz get wind of the topic and look into it.


I agree!