Cannot Use Plugin in Affinity Photo

As of Ver. 2 both Sharpen AI and Denoise AI no longer run as plugins from Affinity Photo. They’ve always run before the updates. When I attempt to run them I get an Error: launch plug-in failure and it locks Affinity Photo up solid where I have to end task. Studio 2 still works and I can access both of them through that, but I’m going to miss using them through Affinity please help.

I use Affinity extensivly and have no issues. You need to make sure that you only have one version of Sharpen AI and DeNoise AI installed, the latest, then have the following settings in Photoshop Plugins:


1 Like

I do only have one version installed (latest) and I have the correct folders selected in Affinity like you show in your screenshot. This is strange I’ve been using them together for quite awhile and never had problems before the updates.

I just tried using sharpen AI in Affinity Photo and it opened the old version. I then deleted the old version and mad sure AP was pointing to the correct directory for Sharpen 2 and still nothing. I also ran SAI 2 as a stand alone but that did not fix the problem. Something is wrong with the install.

I found a fix for this issue. Affinity Photo will auto detect a plugin if it is in the C:ProgramData/affinity/Photo/Plugins directory. Just add a folder called Topaz and then drag a copy of the .*8bf file into it.
For Windows 10 X64 the file is tltopazsharpenaips_x64.8bf and is found in the PS_PluginsX64 folder under Topaz Sharpen AI (be sure its the new version).



Thanks, That works! I don’t understand why now we have to jump through hoops but I’m glad it works. I had tried reinstalling everything to to no avail. Back to normal now, Thanks again!

Just be aware that you will need to update this each and every time there is a update, note the files are *.8BF extensions. The correct way is to update the search folders as in:

But that doesn’t work for me anymore, it used to! but as of Ver 2.0 it no longer works, I’ve tried everything. The Plug-in folder works so I will stick with that for the foreseeable future.

I suspect you have 2 copies installed, just check your program folder as the install location changed with this update.

No I don’t, I uninstalled everything and started from scratch and it still didn’t work. I’m ok with using the Affinity Plug-in folder.

Don, I found the problem. After un-installing the older version of Sharpen AI which was located under the Program files >Topaz folder, it left the *.8bf file. The new version was installed under Topaz LLC. Affinity Photo would see the old file version first and not use the new one. Deleting Sharpen AI folder under the older Topaz heading allows Affinity to work correctly if it is pointed to the new Topaz LLC directory. If someone has copied the *8bf file into the Program Data folder as I showed as a fix, they should delete that as well.

Strange because in my case uninstalling deleted the whole folder. But the solution is good for where it happens.

You’re theory sounds good but it didn’t work for me. I had cleaned out all folders and started from scratch and it still didn’t work. The Affinity Plug-in folder is working for me so I will stick with that.

well, I tried and it worked for me so I’m glad the back up plan helps too.


Thanks, I appreciate all your work! :slight_smile:

I have an issue on my iMac!
Why is the update not installed on the same location?
Never encountered such a amateurish approach of updating a application.
Even this is a problem for Topaz! Every other software company get this right!

Of course I managed to change the Path, but I think the common user doesn’t know how to do that!

1 Like