Anyone use Mac + eGPU

I’m looking at Sonnet eGFX Breakaway Box 550 or AKiTiO Node Titan Do anyone you guys have any experience using these and what results you seen?

I’m using:

  • Sonnet eGFX Breakaway Box with 650W Power Supply
  • XFX Force Radeon RX 5700 XT THICC III Ultra Graphics Card

I had some issues at first with some of the Topaz tools, lots of reinstalling and rebooting, but it all worked out after a bit of that sort of troubleshooting. When I used it with my Macbook Pro the performance difference was around 10%. But using it with my newer iMac it’s been 50% faster than on the Macbook. Something that was to take 10 hours on the Macbook with eGPU is taking 5 on the iMac with eGPU. Notice I’m comparing Macbook to iMac though…

I never ran a test with ONLY the iMac and then iMac + eGPU.

But if you’re only wondering “does it work and are their performance increases” I can say “yes, for me”.

Thats some awesome feedback, what year is your macbook pro and imac?

2018 Macbook Pro? And 2019 iMac.

I got a 2018 MacBook Pro and a Razer Core X Chroma with a Radeon RX 5700 XT.

I can confirm the supported models are running vastly faster on the eGPU. Setup was easy.

Sadly the Gaia model is still CPU only, would love to see how this one performs.

Uh… ask me anything?

I ordered AKiTiO Node Titan
eGPU Enclosure with Radeon RX 580 GPU Bundle

https://eshop.macsales.com/item/AKiTiO/NPTNT3R580/

I should have it in the next week or so, I will use this with my MacBook Pro (16-inch, 2019) 2.4 GHz 8-Core Intel Core i9 / AMD Radeon Pro 5500M 8 GB

I will post results once I have them

Current version definitely works even with questionably supported hardware. I am using a late 2013 retina macbook pro with Aktio Node 3 eGPU with a radeon rx-570, which requires the use of purge-wrangler as its a TB 2.0 machine, and it works fine - certainly faster than the CPU or the nvidia GTX-750m built in. It doesn’t hold a candle to my pc with an RTX 3070 which is roughly 10-12x faster. Haven’t yet tried running the RTX in my egpu but might give it a shot at some point - not sure if it’ll work given lack of official VEAI support for nvidia egpu on macs.

Have you seen any results? I’m a n00b to this app and have a 2013 Mac Pro. I’m running tests on the on-board GPU. I’ve set 1 of the GPUs to be dedicated to Topaz. Gaia-HD is running about 2-3 seconds per frame on average across various input media types.