AI Sharpen takes forever

Trying the plug in for the first time on this computer. Love the improvement that the software provides, but after apply was clicked, it took approximately 7 minutes to update a sharpen adjustment. Obviously (I hope), this indicates there is a problem somewhere as I can’t imagine that this is acceptable to anyone.


Could you update the following so we can check what is happening:

  • How large, in pixels, is the image you are trying to sharpen, and
  • what are the settings you are using, simply post a screenshot of the application with the settings is OK. Then,
  • go to Help-> Graphics Info then click the Copy button on the dialog and post that information in the thread.

Sorry Don, I don’t know my way around the forum yet as I have only been a
Topaz customer since 2010.:innocent:. The info you asked for is as follows, the
original file size in pixels is 21.6 mp, Please see the attached files
for the other 2 items (screenshot before clicking apply, and the Graphics
info copied to Notepad. By the way, I posted this because I am having a
hard time getting my account(s) synced and was hoping to elicit a response.
to beg someone to get in touch with me about that. You have even used an
email address that I would not have anticipated. My normal address is
… as most software from Topaz is located there. I do
appreciate you interest in this performance issue however.

Graphics info.txt (237 Bytes)

The general slowness is caused by a slow GPU, the Intel(R) HD Graphics 530. So do you have dual graphics on your PC, for example I have a Intel HD 630 and a NVIDIA GTX 1050. If you do then you should allocate the High-Performance GPU to the applications.

You will need to raise a support request at the Need Help? link above and please don’t post email addresses on this forum as it is public.

I didn’t realize that my graphic card wasn’t being used for Topaz. I went to preferences and switched to the GPU and the operation that previously took 7 minutes, now takes about 45 seconds. Not as fast as I would like, but at least I can live with it. And this was a very large file as well. Thanks for the heads up.

1 Like