AI models fail to download it appears

I just bought Video AI, downloaded v 3.0.5 and wanted to use it.
I’ve previously test-driven v2 and it worked.

But if you clear out the folder with the AI models, then restart the software and try to preview any filter, it fails immediately at “Download model”. (- Error message from AI engine: download failed.)
The folder also doesn’t have any downloaded models in it.

I’ve also tried to go back to v 3.0.4 but it is the same with this version.

There are two different folders that are named ‘models’. Did you delete the .tz files or the .json files?

I used the folder which appears in the preferences dialog of TVEAI. (default location)
I emptied it out completely.
After a reinstallation it gets populated with quite a few small .json files.
But the only .tz file in it is named and is 59 KB.

Any filter I am trying is failing with “Download model”. (- Error message from AI engine: download failed.)

I’ve enabled the detailed logging, then repeated the test and inspected the log.
I found this:

2022-12-06 12-49-06 Thread: 20944 Info OUT: 2 2022-12-06 12-49-06 Thread: 12036 Info RESULT for /  is  403

2022-12-06 12-49-06 Thread: 12036 Critical Attempt 2 failed for /

:AIERROR: Download Failed
2022-12-06 12-49-06 Thread: 12036 Info Waiting for download of  "" "C:\\ProgramData\\Topaz Labs LLC\\Topaz Video AI\\models\\/"

2022-12-06 12-49-06 Thread: 12036 Info Status: 3 message: "Waiting to download file"


There is a space character in the download URL of the model, before the last slash.

So I copied the URL into the address bar of my browser, removed the space character and promptly received the .tz file.

I had to repeat this 3 times for different .tz files (and fend off accusations by the webserver that I am a bot), then the preview did run (although slower than I am used to with that filter, so it might not be using the GPU as intended).

It looks quite likely that there is an issue with generating valid URLs for downloading the AI models.

There was also this error:

2022-12-06 12-57-52 Thread: 12596 Info OUT: 2 2022-12-06 12-57-52 Thread: 20492 Warning ModelManager: Unable to parse json file:  C:/ProgramData/Topaz Labs LLC/Topaz Video AI/models/encoders.json

which is puzzling because the encoders.json file does exist in this location and looks quite like a valid .json file.

I’ve also found this error (after downloading the .tz file manually), which might shed further light on the issue:

2022-12-06 13-14-15 Thread: 8172 Info OUT: 2 2022-12-06 13-14-15 Thread: 4408 Critical Loading default error reading file:  "C:\\ProgramData\\Topaz Labs LLC\\Topaz Video AI\\models\\/"

:AIERROR: Model Failed

2022-12-06 13-14-15 Thread: 8172 Info OUT: 2 2022-12-06 13-14-15 Thread: 4408 Critical Unable to create or load model of type  tensorrt  from path:  ""

2022-12-06 13-14-15 Thread: 4408 Critical BackendRunner cannot be initialized for model:  ""

2022-12-06 13-14-15 Thread: 4408 Critical Model Runner init failed for index:  0

It might be taking offense on the single slash before the file name, after the last pair of double backslashes.
Or maybe not, because further down I can see it successfully loading other .tz files with the same weird path name makeup.

Maybe this has something to to with the issue:

2022-12-06 13-43-57 Thread: 22396 Info Creating file fetcher for:  REMOTE DIR:  /

Not sure then. I do know that it should have problems downloading them without the json files.
I have mine set to put the tz files on a bigger drive. I think re-installing should have fixed it all for you.

Does your folder also have the auth.tpz file?

Yes, it does. I understand that’s what stores your user account login for the licensing.

I’m all out of ideas then. Sorry.

Thank you for your time!

I was kinda hoping that some Topaz Labs employeee would jump at it and go “gee, we might have a tiny bug in our systems.”

I have the same problem with “Error message from AI engine: download fails” also in last version 3.0.9.
Is there any solution?

yeah same just downloaded it grabbed a file to test and bam

I’m getting the same error while trying to download SOME of the models. Topaz?

Also getting this same error

Same problem here with Ver 3 and Ver 4. If I try to process a file the model download stays at 0 bytes downloaded for ever with the animated dots. Earlier version 2.64 works fine.