AI Gigapixel weird grid created in images

HAS ANYONE ELSE FOUND STRANGE GRIDS IN THEIR PHOTOS?

I have a SONY A7R and converted the ARW file to DNG with Adobe DNG converter. You can see the original DNG file below and I zoomed right in out of it trying to find any sign of a grid but there is nothing. It’s a clean blue sky!

First off Processing time on a 3.2Ghz i5-2500k, 16GB RAM, Windows 10 was 60minutes. Processed the same file on 2015 MacBook Pro 3.3Ghz, SSD, 15in retina was 30minutes.

But the bug I noticed was that the software created this strange grid in the blue sky. I will post 3 images to exhibit what I mean. I layered the original photo and the AI gigapixel file in photoshop and then exaggerated the grid with a simple curves adjustment so that you can see it better online.

Original DNG Photo shot on Sony A7r - Layer 1 (top Layer in Photoshop)

Topaz AI gigapixel Image where you can see the light grid when zoomed in on the photo (Layer 0)

This is the image where I just did a curves adjustment where I increased the highlights and decreased the shadows so that the strange grid would be more visible. It’s so odd right?

1 Like

I have noticed this same grid with a completely different camera, Nikon D5100. I wanted to use an older camera with smaller files to see how the processing time compared to the full frame Sony A7r files.

I have opened the resultant image in Adobe Photoshop and then created the adjustment layer and increased highlights and dropped shadows to exaggerate the grid so you can see it.

I looked around the image and this grid is visible all over it, not just in blue skies. It appears to be an issue with the software where it still has a boxed grid, perhaps something leftover from the way the software analyzes and processes the data???

Down near the mountains and sunset colours, you can see the grid goes over the entire image.

Anyway, I have now noticed this on 2 different cameras - Sony A7r and NIkon D5100. So pretty sure it’s a software issue.

Maybe others could repeat what I did and see if they have a grid too? This is the Adjustments I made in Curves

Hi,

I can see that in your image with the curve applied but I don’t see anything using a JPEG and upsizing that on my PC, can you also please post the following information:

  • What images are you using to upsize, i.e. RAW, DNG, JPEG, TIFF or PNG?
  • What is your GPU that you are using, what is the dedicated vRAM the GPU has (not system RAM)?
  • Did you process the same image on the Windows & Mac PC’s and did you see the same grid on both?

Hi,

  • Sony A7r files were DNG using the latest official Adobe DNG converter.

  • Nikon D5100 files are RAW

  • GPU is Radeon 6950 with 2GB dedicated vRAM.

  • This only seems to happen on the Windows PC and not Macbook PRO.

Hi,

I can see the problem on your images but I cannot reproduce it myself using DNG or CR2 & RAF images and zooming up to 10x in either AP or PS, note that the current version of the Adobe DNG Converter is v10.4.0.976 and make sure that your GPU drivers are updated from the AMD website.

Please raise a support request at the link in the Need Help panel at the top of the page and then choose Open a Request on the page and you will need to choose Plugin Support (Plugins: … etc) and Gigapixel appears in the Product drop-down list.

Hi Don —

I’ve been using AI Gigapixel for several days now, and although I’ve been pretty happy with the results, enough that I actually purchased it yesterday, I have now had a peculiar result when operating on a jpeg. The result was not a grid, but bands in a nearly uniform gray sky (B&W image). At first I thought it might be peculiar to that image alone, but I made smaller and smaller crops of the original with the same result, and ended with a uniform gray image of about the same value as the sky in the original. There were darker bands in the uniform gray image:


noise reduction on 4x scaled image. This is exactly how it looked with no further editing. I could increase the contrast if that would help in analyzing the image.
Any ideas?

— Frank

I just enhanced the contrast of the above image and I see that it is, in fact, a grid:

Have no idea as I haven’t seen anything like this before so I would suggest you raise a technical support request at the link above in the header on the page.

The GigaPixel support is accessed through the Plugins link.

This looks like a processing artifact where large areas of uniform color create a reflection of the underlying matrix used to cut the image up into manageable sections for analysis. The boundaries between sections have a mathematical edge that it looks like they are not successfully suppressing. They would either have to add a preprocessing pass to mark off these areas to avoid it, or remove it with a post process step that specifically eliminates this pattern.

Have you had help in resolving your problem, Luke?
I have the same problem as you probably saw, and my help request has not been resolved. The results of my personal study of the problem are in an album on my Flickr site: https://www.flickr.com/photos/f_magalhaes/albums/72157700165428731 if you are interested.
— Frank

Update:

Version 2.0 behaves in the same way as the previous version. Problem persists.

I didn’t get any solution so didn’t implement it into my workflow. Just stuck with other resizing solutions.

We’ll be addressing the grid in an update coming soon. Thanks!

Thanks! Looking forward to it since I have the same problems, but just with 4x resize with reduce noise and blur on “moderate” or “strong”. Otherwise there are no grid occurrences.

I just installed the newest release minutes ago…

Regards,
Joe

A.I. Gigapixel’s immediate focus at the moment is on the GUI and a pesky banding issue that has arisen. We’re keeping the grid issue high on our priority list for future updates :slight_smile:

1 Like

Thank you! I am a recent adopter, and the results so far have matched the hype :grin: I too have noticed this grid show up in grayish areas, however I see dashed lines that I have been manually removing (the grid pattern lines up perfectly with these dashed lines I see in clouds and misty waterfall areas of my photos). Can’t wait for an update to take care of this issue.

Update. I have just tried processing an image with cpu, not gpu, and the grid pattern is a lot less apparent. To the point I no longer see the dashed lines.

The first image is with GPU processing, the second with CPU:

Some underlying pattern only becomes visible by this extreme curves adjustment, but the dashed lines disappear completely.

As a brand new user, I too, have had the dashed lines show up but did not identify what I did to get that. Using ISO 6400 images from a Canon SL1, I have also been having weird “crop circles” and more like focus screen lines show up and last week a large target outer circle. I figured the camera was subtly imaging its own innards but this does not show up until analyzed to the extreme by this software.

1 Like

I’ve got the dashed lines problem too! When can we expect a fix for this? It’s a real pain in the bum to meticulously hunt them down and clone them out every time I enlarge an image. Sometimes I miss some and later find out they’re over an important subject/feature in the photo. :confused:

My hardware and software configuration:
CPU: AMD Threadripper 1950X / RAM: 32 GB / GPU: ASUS GTX 1080 Ti 11GB Founder’s Edition / OS: Windows 10 Pro 1809 / Topaz AI Gigapixel version 3.1.1

1 Like

Hi,

Not sure this issue is the same, but we found many horizontal lines across an entire image resized with AI Gigapixel.

Yo can see them repeated across the entire image as a pattern or perhaps a Grid, but i didnt find vertical lines.

The whole image with lines localized. You can see them often and always in the guide intersections.

This happens in two different iMacs, with AI GIGAPIXEL 3.1.1 one in my Advertising agency and other at home.

The same effect at any resize level from tiff or jpg sources. Of course, some different photos used to check before this comment.

This tool would be useful but we can´t work with it if this happens. What to do? Not happy about that.