Affinity TS2 plugin glitch Windows

I have already submitted a support ticket for this but I thought I would ask here just in case anyone would have an idea.
I updated to the latest version of TS2 v2.2.0 and all went well, no problems, BUT I cannot get TS2 to show up in my Affinity plugins list. I went through all the regular steps to add it - edit/preferences/psplugins then choosing the Topaz Labs LLC folder (with the check in the "allow unknown plugins) but it just does not show up after the restart. Affinity v1.7.3.481, Win v10.0.17763.864. All of my other Topaz products show up - DeNoise AI, Sharpen AI and Adjust AI, the old original Topaz Studio, just not TS2. I also tried the same steps but choosing the Topaz Labs LLC\Topaz Studio 2 folder - same result. Any ideas?

Hi, If you have selected it correctly it will show on its own in the Topaz Studio 2 entry in filters like this:


Your Plugins search folders should look like this, note the Program Files (x86)\Topaz Labs is for previous, older plugins:


Here are my relevant screenshots - I believe I have done it correctly…

Just delete the first two entries that are DeNoise AI and Sharpen AI because they are already in the \Topaz Labs\ folder which you have specified as the last.

Make sure you don’t have a Topaz Studio 2 folder in the Topaz Labs folder because it should have been uninstalled when you updated to 2.2.0.

Okay I’ll try that. I do have a topaz studio 2 folder in the topaz labs folder but it’s empty.

OK did that, no different result - here are my current screenshots.

One other thing, in my current version topaz 2 file structure should there be a Photoshop plug-in file folder or just a plug-in file folder? If there is supposed to be a plug-in file folder of some sort it seems to be missing in my file structure.

Just an FYI - I have solved the problem! I determined through conversations with others that I was missing the plugin files in the topaz studio2, v2.2. somehow they didn’t install correctly even though I used the installer on the website. Anyway I uninstalled and reinstalled V2.2 and the files downloaded correctly that time and the problem is solved -Studio 2 now shows up in my Affinity plugins menu! Thanks for your time!

1 Like

Two folders as per screen shot

Thanks but if you read above you’ll see that I solved the problem. I determined that somehow or another the plug-in files did not get downloaded during my initial installation, I was missing those file folders. I have uninstalled and reinstalled and this time everything downloaded and installed correctly. They plug in files are there and everything is solved now as the plug-in shows up correctly in my Affinity program. Thanks for your reply.