Affinity Photo -> Impression-2 Legacy plugin failure

AFP: v1.8.3 Windows-10

~ Affinity Photo & Impression-2 worked at some point in the past. Not sure of last version that worked.
~ Impression-2 stand-alone still works.

However, calling IMP-2 from AFP (plugin) now gives an error.

Anyone have this combo working?

1 Like

Hi John, Doesn’t seem to be a problem here on Windows 10 and my Plugins are setup like this without moving the actual plugins into the default directory for AP (excepting NIK Collection):

Yes, I am on Windows-10 and my paths are essentially the same.

I didn’t mention that all my other Topaz Legacy plugins are working. eg Simplify-4 working as expected.

Side note: Why is Legacy-Nik able to report status, but Topaz plugins are not?


It seems unusual as for the Unknown it just means “untested” or “Possible incompatibility”

Just check you have your plugins the same as this because it will pick up the first in the directories, and as Topaz Studio comes last it’s plugins aren’t picked up:

Also click on Open Default Folder on the plugins panel and make sure there isn’t a 8BF file for Impression in that folder.

Nope, empty.

Also, I subsequently observed that it is not a question of AFP finding the Impression plugin…it does. Because when I temporarily move the plugin out of it’s home folder, and restart AFP, then Impression no longer shows up in the filter menu. So, that tells me that AFP is finding the plugin where it expects to.

What version of Affinity Photo are you running?

Version 1.8.3 .641, i think it is the latest.

The only other thing I can think of is reset the preferences. Press Control while starting up and you should see this dialog appear:


Then select any of the settings you want to reset. You can even press Select All if you want to reset everything.