About trying Topaz Video AI

In this case it might be better to first downsize the video (e.g. with handbrake, should be very fast) and only then upscale it in TVAI 2x with Iris or Proteus.
Otherwise you would need MUCH more time and get a really large file, because it would end up as 4k video but without being near to 4k from the amount of detail.
A bit as it is now: formally 1080p resolution but details only like a bad SD.

So I guess my workflow on this would be:
Handbrake with halving the resolution in both axes. Then load the resulting video into TVAI. There it could be good approach to start with the “Upscale to HD resolution” preset

Bildschirmfoto 2023-12-01 um 17.34.16
I would only turn on stabilization and Deblur if really necessary. Upscaling 2x automatically enables “Enhancement” where you can then chose the used model:

The preset uses Proteus which isn’t bad at all - but I mostly prefer Iris.

These are my preferred settings for LQ SD material:

Hi @jo.vo

Now I upload another .mp4 video trimmed on the original video which was ripped by the profession shop on my old Sony V8 tapes. The trimmed .mp4 video is untouched. I ran ffmepg command on Terminal to get it done on time basis, i.e. according to duration.

I haven’t downsized the video and made following test

Enable → Stabilization
Full-Frame
Strength → moving the slide without any action on the Preview of the video
Preview → 5s

There is no response.

Warning on the Preview window:
Not Processed
To preview your settings click the Preview Button below
(Pls refers to screenshot attached)

Did I commit any mistake? Thanks

Regards

Hi @eh117

Preference - Pls refers to screenshot

Regards

  1. Is your video that shaky that you want to only enable stabilisation?
    Try the Upscale to HD preset, it’s not that bad as a starting point.

  2. after clicking on the down arrow at the preview button and choosing the preview length you of course have to click on the preview button itself…

Under the ‘Processing’ pane, which processor are you using?

Also, on the main interface, go to Process > Open Command Prompt and run this script.

@REM For version 3.5.0
@echo off
setlocal enabledelayedexpansion
set device=-2
for %%i in ("480x360", "640x480", "720x480", "768x576", "1280x720", "1920x1080", "3840x2160") do (
    for %%m in (aaa-9, ahq-12, alq-13, alqs-2, amq-13, amqs-2, ddv-3, dtd-4, dtds-2, dtv-4, dtvs-2, gcg-5, ghq-5, prob-3, thd-3, thf-4, thm-2, prap-3, iris-1, iris-2, nyx-1, nyx-2, nap-1, nap-2) do (
        for %%s in (1, 2, 4) do (
            ffmpeg.exe -nostats -hide_banner -f lavfi -i color=c=red@0.8:duration=0.01:rate=100:size=%%i -vf tvai_up=model=%%m:scale=%%s:device=%device%:vram=1:instances=0 -f null -
        )
    )
    for %%m in (ifi-1, chf-3, chr-2, apo-8, apf-1) do (
        ffmpeg.exe -nostats -hide_banner -f lavfi -i color=c=red@0.8:duration=0.01:rate=100:size=%%i -vf tvai_fi=model=%%m:device=%device%:vram=1:instances=0 -f null -
    )
)


The problems you are describing suggest that the API is not communicating with the server.

Click the Preview Button, not the arrow.

Hi @Ihkjacky Jacky

When I select [Stabilizaion A]
Preview window turns to a dark screen

Clicking [Preview (5s)] button (big button), there is no response, still a dark screen

→ start Run, still the same

I have tried several times. Have I committed any mistake?

Hi @jo.vo

  1. The video is blury, not only shaky. That are the problems which I expect to correct.
  1. I have chosen 5s and then click the Preview button (big buttom) without response, still a dark screen. I have tried many times.

Hi @eh117

Under ‘Processing’ pane, I select ‘Fit’

Process > Open Command Prompt
Paste your script
But how to run it?

Or save your script as a file, say ABC.exe running VIM editor?
chmod +x ABC.exe
then run ABC.exe there?

Hi @Ihkjacky

Is it download “Models-v4.bat.zip (1.1 KB) (Windows)” to Windows 11 ?

Unzip the file

Select the bat file → right-click → Run as Administrator ?

  1. Download the Zip file and Unzip
  2. Open the terminal from inside the app
  3. Run the bat file

The script downloads all the AI models to your computer. However, you shouldn’t need to do it. TVAI should automatically download those models when needed. I don’t think the script can fix the preview problem. But you can try it anyway. It will download roughly 15GB of files to your computer.

Then I guess @eh117 is right and there’s a problem with the function of the GUI.

Anyways this will be hard to impossible to tell as no one really knows your untypical setup.

A VM really isn’t well suited to run apps like TVAI (or gaming).

Hi @jo.vo

If it is the problem of GUI, why other buttons are working without problem, such as Stabilization, Motion Deblur, Frame Interpolation, Enhancement and Grain. They are operated via GUI and work without problem, being activated with a click.

Nowadays software(applications), unable to run on VM/Guest of Virtualizer and requiring bare-metal to run, are very rare. If it is the case, the developers will indicate on their software that the software require bare-metal to run .

I have following graphic design and multimedia software running on VM for years without problem;
GIMP, Photoshop, VLC, Darktable, ShotCut, Kdnlives, Blender, Inkscape, DaVinci Resolve

Hello Satimis…

You still haven’t told us which processor the device is using.

And, did you successfully download the models to the program directory?

1 Like

I have following graphic design and multimedia software running on VM for years without problem;
GIMP, Photoshop, VLC, Darktable, ShotCut, Kdnlives, Blender, Inkscape, DaVinci Resolve

Sorry Satimis, I just have to ask… why are you running GIMP, VLC, Shotcut, Kdenlive, Blender, and Inkscape on a VM?? All of them run on Linux. Even Resolve runs just fine on Linux. :confused:

Hi @eh117,

The answer is very simple.

The host of VirtualBox is Ubuntu 22.04. There are about 20 VMs running on this system.

I won’t touch the host after its installation. All works and tests are done on VMs. Should I make serious mistakes on a VM, I just delete the VM and clone a new VM. The whole system is not affected. This setup is very convenient and safe.

Besides I have 40 duplicate websites running on VMs in this system. Their live-sites are running on Internet. Some VMs have Docker running on top.

The PC has been running for more than 6 years without problem. All important data are stored separately on a 4TB hard drive in this PC.

I suppose Topaz works on Ubuntu 22.04 Linux

Not natively, although you can get it to run on Wine. But it will only run on CPU.

@satimis Any updates on the status of your Topaz installation?

Also, I managed to get some other video AI programs running on Linux (on GPU) and they run wonderfully - no VM involved. I suppose the same is possible with TVAI, but I already have TVAI on two other devices.

Hi @eh117,

I suspose I have to find a spare SSD to continue the test on Topaz Video AI. I won’t touch the Host.

Regards