Why Doesn't Topaz Studio 1 Work With XPS 8940?

I just bought the XPS 8940 with Windows 10 Professional and discovered that it would not run Topaz Studio 1 no matter what I tried. Does anyone up here know why? I like this Topaz program very much.
It works fine on my XPS 8700 with Windows 7 Professional. It also works fine on my two Dell Windows 10 Home laptops. The 8940 will also run my copy of Topaz Studio 2. Very strange behavior!
Thank you very much.
topazatha

Have a look in the Event Viewer to see if there are any messages. Also try changing the compatibility settings e.g. to Win 8.1, Win 7 etc.

Thank you, Aidon. I already tried all possible compatibility cases. I don’t know how to look for messages in the Event Viewer. I should mention that, in addition, neither Impression 2 nor Texture 2 work.
Thank you again.
topazatha

New Dell XPS 8940 owner here with same problem; also not working Topaz Glow. Help!

These products are discontinued so you will need to rely on users here with similar hardware or try the Dell forums.

I have downloaded and installed all the legacy products which I own on my new computer. They all work fine except for Glow, Impression, Texture Effects and Studio 1, which seem to install with no problem, but when I start them up they get about half-way (opening screen shows) and then quit. Any suggestions as to what’s going on here would be much appreciated. (The fact that it’s a Dell computer would seem to be irrelevant to this issue.)

Dell computers have always had issues, especially with drivers and ICC profiles. I suggest you look on the Dell forums.

I have had no problems using Topaz programs on many Dell computers in the past. Moreover, there are no problems running the Topaz suite of programs (both legacy and current) on my new computer except for the few mentioned above. Thus, I find it unlikely that the problems are attributable to the manyfacturer of the computer.

dnarub,
If you discover anything positive, please be kind enough to let me know. I will do the same myself.
Thank you!

“Would not run”???.
It might help get you worthwhile answers if you elaborated on this. Are you referring to trying to run it as a plug-in to some particular host program, or in free-standing mode?. Does something happen when you try to open it, does it part open and hang, part open and crash, or does absolutely nothing appear to happen.

Does it open far enough in freestanding mode to show the “drag and drop here to start” message, and then fail in some way at a subsequent stage?

If you have Task Manager open when you start Studio, do you see an entry appear under Apps for “Topaz Studio.exe”, and if such entry does appear, is it still there after Studio does whatever it is actually doing, or not doing.

I assume you have re-booted your PC between tries so that app shouldn’t be showing when you first open Task Manager.

Have you tried starting Studio in free standing mode using “run as Administrator”?.
Windows will see this app as “Publisher unknown” and your security settings might be having some effect.

All I can confirm at the moment is that Studio 1.14.5 does run OK under Windows 10 Pro, 21H1 build 19043.1083, on an Intel i7-10-700 Gen 10 CPU, both free standing and as a plug-in from Affinity Photo and ACDSee Ultimate.

Greyfox,

Thank you very much for your response.
I have a Windows 10 Pro 64-bit (10.0, Build 19042) (19041.vb_release.191206-1406).
The processor is 11th Gen Intel® Core™ i9-11900 @ 2.50GHz (16 CPUs), ~2.5GHz.
All I see when I run the program as an administrator is the screen with “Welcome to Topaz Studio”
for a few seconds, and then nothing. The screen dies and disappears.
The task manager shows Topaz Studio in the Apps section during that particular time interval.
This happens when I run the program as a plugin to several Photoshop editions (CS6, CC 2020, CC2021) or as
a stand alone application. The program runs fine on my Dell XPS 8700 with Windows 7
professional.
Thank you, again.

One thing that might provide some worthwhile information as to the cause of this is if Windows is creating an Event, or series of events when the program fails. For that you will need to get some understanding of how to use Event Viewer. Basically you will be looking for any error event, or information event that matches the time when you try to open Studio 1.

The other thing is the log files that Studio 1 can create. Studio 1’s logging is disabled by default and is normally enabled from within the program from Help->Enable File logging. Since the program is not opening far enough to allow you to enable logging from there, the only other way to enable it is via a Registry change. If (and only if) you are comfortable with making registry changes, the key involved is HKCU\SOFTWARE\Topaz Labs\Topaz Studio\appMain\FileLoggingEnabled. You would need to change it from “false” to “true”.

When you then next try to start Studio 1, it should generate a log file at C:\Users\Yourname\Appdata\Local\Topaz Labs\Topaz Studio\Logs. The file name will include a timestamp, so for example 2021-07-09-12-18-28-Main.tzlog. If it gets far enough it will also generate one called 2021-07-09-12-18-28-QML.tzlog.

Those log files can be opened in Windows Notepad. Analyzing them won’t be easy because even when the program runs seemingly properly the logging generates a lot of Warnings, but if you are lucky they might provide some clues.

Beyond that and making sure your device drivers, particularly the graphics drivers are up to date, you could try temporarily putting the entire Studio 2 program directory as an exclusion from your Antivirus/Malware software. You can also try temporarily disconnecting your PC from on line. It is not uncommon for applications to communicate with home during the splash screen up time (registration checks etc) and perhaps it doesn’t get the answer it is looking for. Studio 1 will open and work (at least for some time) with no on line connection present.

Thank you, again, Greyfox. I have already decided to give up. I have bought a KVM switch that will allow me to use Topaz Studio 1 on my XPS 8700 which will be sharing the same keyboard, Monitor and mouse with my XPS 8940. I will be also using Impression 2, Textures 2 and other plugins this way. I did make the change in the registry and looked at the two logs. I can get no information from them. I appreciate your effort to help me.
topazatha

Right click on programs in Start menu or find the programs where installed on your drive, select Properties, then Compatibility. Try different settings or there is a compatibility troubleshooter.

I have tried much more elaborate things, Rondo249. Nothing ever worked. I even found a copy of version 1.11.8. That didn’t work either. I have given up. I am using a kvm switch with two computers sharing the same keyboard, monitor and mouse. One of them has Windows 7, 64 bit, and I use it to run Topaz Studio.
Thank you.

perloquito-405920

As no mention made of a GPU I figure that this is just the onboard graphics chip being used. It’s fairly low spec.
Quote] “The exact performance of the UHD Graphics 630 depends on various factors like TDP, L3 Cache, memory (DDR3/DDR4) and maximum clock rate of the specific model. However, it should be fairly similar to the HD Graphics 530 and HD Graphics 630 and therefore only suited for low demanding games…”[Unquote.
Uses system memory only.
Have you tried a proper video card?
Your old computer XPS 8700 is listed by Dell as having it’s own graphics card.
Might be all your problem is. Not a Topaz fault at all?

Me either. I never have a problem with Dell, and as a software consultant I have had many of them, as well as consulted on them. There was only one 13" XPS (with decent specs) that I could not run Studio 1 on…even had Ashley from Topaz remotely try to get it to run without success. Same issue…would get to the splash screen then quit. Previous 13" XPS ran it fine with less specs. Never did figure it out. My other laptops and desktops from Dell all run it fine. Sure wish they’d get back to finishing Studio 2 to have the features of 1, which I still use.

I even installed Windows 10 Home into my Windows 10 Pro without losing any files. Again, nothing happened with Topaz Studio 1. There is definitely something that has to do with the two graphics cards of the XPS 8940. Nothing wrong with the 27" monitor.
topazatha

After trying some of the suggestions above, without success, I’ve pretty much given up on getting Studio 1 (as well as Glow, Impression and Texture Effects) to run on the Dell 8940. Of course Studio 2 incorporates all of these legacy programs, (and more), but I had become familiar with the earlier versions, and in many ways found them preferable to their Studio 2 incarnations. So now I feel I have no alternative but to become more adept with Studio 2 and to figure out how to work within its limitations. If you ever figure out a solution to this issue I hope you would make it known on this forum.

Of course!