Where is Studio Saving to?

Topaz Studio was letting me save to LR6 but has stopped again for some reason. (using Windows 10, haven’t downloaded last week’s update yet as lots of problems have been reported). After applying a plug-in effect, and returning to Studio, the Save button is greyed out. I have to hit APPLY to make the SAVE button light up. However, when I click on Save, I get the box that asks what format I want to save the photo in but no options as to where it’s saving. The photo doesn’t go back to LR6, and I have no idea where the photos are saving to.

At the point where you return to Studio and the Save button is greyed out, try moving the Opacity slider, just above the save button, down a bit. Since you’re not applying any new effect, nothing on your image should change, but the Save button should light up, since you’ve technically changed something. The Save button won’t be available until a change to a setting is detected, so that should enable you to save back to LR.


Okay, got the SAVE button issue resolved. The SAVE button will highlight after I move the opacity slider just a bit. It still isn’t saving back to LR6, though, and it doesn’t ask me where I want to save to. I click on SAVE, get a box that asks if I want to save in SRBG or ProSRBG, 8 Bits or 16 Bits, and TIFF or ZIP. Once I click SAVE, that’s it, the box goes away. The edited photo doesn’t go back to LR6, and I actually don’t have any idea exactly where the pictures are going.

Please make sure you’ve updated to Studio 1.5.3. We have released an update to fix this behavior, so it sounds like you might be using a version that doesn’t have the fix, yet.

I do have 1.5.3. At one point it was saving to LR6 but now it’s not. I haven’t done the latest update to Windows 10 yet because of all the bugs I’ve read. Could that be the problem?

I’m not seeing any issues saving back to the LR catalog on my end. Does this happen with all catalogs? Are any of the problem images located on removable drives? The more information you can provide about your setup, the easier it will be to narrow down what might be happening. Also, are you using the Edit a Copy with Lightroom Adjustments option?

I tried images on both an external hard drive and internal hard drive. Same thing happens either way. I also tried Edit the Original and Edit a Copy, and still the same thing. Every time I hit SAVE, I get the window that asks if I want ProPhoto or SRGB, and if I want TIFF. I tried going to FILE in the upper left, and clicking SAVE AS, so at least I could tell it where on my hard drive to save it, but I still don’t even get an option of where to save the photo to there either. I have no idea where the photos are going when I save them.

I’ll be glad to give you any information you need to help resolve the problem.

Just did a little workaround. If I send the photo from LR6 to Photoshop CS5 then to Topaz Studio, Studio will save back to CS5, then back to LR6.

I just opened Studio bare to try out Glow. I modified a photo (luckily a copy) then clicked Save. My button options were Exit and Save. It asked what quality. but then boom overwrote my original. One would think that Topaz would support the never overwrite an original mantra by at least giving an option. Yes, of course I can go File - Save As…

Usually I would work through Photoshop.

An “are you sure you want to overwrite” prompt could have helped avoid this, I can agree. I’ll add it to the list.

One trick you can use, if you accidentally overwrite your original, is to undo your changes back to the beginning, and resave.