Video Enhance v2.6.4

Hello, I don’t know if I’ve already mentioned it, but there is a rather disturbing bug that almost always occurs the first time you open the software after starting the operating system.
PS, I’m on Windows 10.

The problem is that once the software is open and I want to import my video (in this case an episode of a series) the first time it does in 95% of the cases I have this as soon as I import my mkv video:

All is grayed out. And I have to delete the file from the software and start again. Or change the template and put back the template I want to use and reconfigure my export settings.
But sometimes I have to restart the import several times before it finally works. But even so I literally have to close the software and start again, otherwise I get the same thing. Everything is black on the preview screen no matter where the timeline cursor is. as on this new image:

Sur les importations dans la journée après avoir terminé une vidéo, il n’y a pas de problème. Il se produit toujours au premier lancement après le démarrage de Windows.
C’est un problème récurrent depuis le début de la 2.6.4. J’espère que la prochaine mise à jour corrigera enfin le problème.

I know I’m not going to be much help here, but I stopped trying to use MKV source video long ago. It simply does not work, because of compatibility issues. I rip DVD in MakeMKV, and then encode to MP4 using Handbrake, plus I can de-interlace at the same time.

Why would you ever re-encode just to change it from MKV to MP4? You’re just changing the container, not the codec so you don’t have to re-encode. All you’re really doing is deliberately degrading your image quality by repeatedly using lossy encoding.

If you’re on MacOS, just use Video Container Switcher, it’s going to take a fraction of the time and won’t degrade your quality. Good luck

Dude. Settle down. I know what I’m doing. The MP4 “container” works best for me, so if you want to keep struggling with MKV, be my guest.

BTW. My final upscale will always be MKV container, so I can add back in 5 channel audio, which VEAI strips out.

1 Like

there will be no update to the 2.6.4 branch. the next update will be VEAI 3.0 or 3.1
il y aura pas de mise a jour a partir de la 2.6.4. la prochaine sera la version 3.0 voire 3.1 de VEAI

There are some good (free!) software solutions that allow you to remux MKV to MP4 without re-encoding, which saves a fair bit of time as well as leaving the video quality untouched. Examples off the top of my head would be Mediacoder or BOX4.

Never really understood why MKV is such a problematic container for so many applications - it’s very annoying!

remuxing a Mkv container to mp4 can be tricky. depending of the player it can fail too. (expecially on TV / Media player), so a small Warning about using it is good to have while doing it. it can work, but in other circonstances, it can fail too.

for curiosity, please, re encode one minute of your entreprise episode in Mp4/H264 (without switching the container without re encode, if it still fail, to see if the problem remain or not. sometimes the issue can come from the codec used as well, if you have this issue from this source only and not other Mkv file. @myorders is right. to work in Vegas Pro, I re encode my files, no other choice, the MKV file that MakeMkv produce are in a format not compatible for editing. so it need the hard way, re encoding, not just container switcher. not even speaking that mkv import is still in beta and work bad in vegas, mkv import doesn’t work in premiere pro too.

MKV is certainly an issue for video editor, like .mts/.m2ts Vob file etc…

1 Like

amazing special effect by hand @harald.de.luca !! :rofl:

“Dude”, you’re still degrading the quality by doing what you’re doing. Period.

I use MKV in VEAI all the time. NEVER ONCE had a problem. Something else is going on.

You need to check that box…

looooool. I never imagined this comparison xd :joy:

Oddly enough, I never had to do this before because it did it automatically. And yet, I have been using the software since version 1.6.x. I must not have realized that it was not activated. I’ll check next time.

As I said, it’s at the first launch of the software after starting Windows. The next time I launch the software, I don’t have the problem anymore.

NB: if I open the software once and then close it and then reopen it: I don’t have the problem anymore either.

I did not test with a mp4 at the first launch of the software. But that’s because here I’m doing image enhancement of the Star Trek series. And the bug I’m talking about is not related to this series. I already had the problem with other series of the same format.

PS, I found a simple and practical way to import MKV and many other formats in Premiere pro/ media encoder and after effect. And it’s thanks to this super powerful plugin: https://aescripts.com/influ

[quote=“harald.de.luca, post:1025, topic:27636”]
And the bug I’m talking about is not related to this series. I already had the problem with other series of the same format.[/quote]
maybe they use the same codec / extension. sometimes i have this issue with my media player, and to watch the file on my tv i must re encode it.

Thanks for the tip ! 'm a vegas pro user, and use premiere only recently (and don’t like it lol).

I’ve been having this weird problem the Proteus filter at 300% scale. I’ve switched to the NVIDIA Studio Drivers from the Game Ready one’s. I’ve reinstalled Topaz Video AI, and also tried underclocking my gpu by 100mhz with MSI Afterburner. But nothing has fixed it.

You are correct, in version 1.x I recall the All option was checked by default. In 2.x there was a shift to more independent queue editing, stabilizing the frame syncing with Audio, etc. Now if you drag-n-drop multiple titles to the drawer, they are all unique jobs, you can set them all up individually, you can even select a single title out of the queue to process leaving the others available for later. Or select all to process all. They did make a pop-up dialog warning you if it appeared there were more titles in the queue than the one when you attempt to start. I run VEAI 2.6.3 as my stable tool. Something with 2.6.4 messed things up, unsure now why. Good luck!