Video Enhance v2.4.0

Wow, Nice !!! (Thanks)

It was 960x540. Here is a 1280x720 to 1920x1080 test from the 1660.

1 Like

I experienced a strange behaviour of VE AI today when I started VE AI, selected “load last save” and then “start processig”. Unfortunately it did not continue where the marker was and begun from start again.

I looked into the file menu if I can load the last save manually but found no option, so closed VE AI and started it again to get the “load last save” option again.

This worked perfectly except that the “last save” was carried on the mistake VE AI did before so again it wanted to start new because that was where it was stoped before.

Is it possible to use the new models in 2.4 in version 2.3, like Proteus v2?

I want to use the command line as part of my workflow and do not want to lose this. I keep testing on 2.3 until this feature is re-added to Topaz. But I would like to test the new models if this is possible?


1 Like

be part of the beta team if you want to help. being part of the beta allow to have installed at the same time the released one and the beta one. just run 2.3 on your computer and have the last beta of 2.4.0 installed if by chance the exe is still available.

Copied from upthread:

So, to get Proteus v2 in 2.3.0, open the following file in Notepad:

C:\Users\[USERNAME]\AppData\Roaming\Topaz Labs LLC\Video Enhance AI\models\proteus-b-1.json

Then change line 3, from:

"version": "1",


"version": "2",

Then to properly use the updated proteus auto model, you need to change line 110 from:

"autoModelKey": "prap-1",


"autoModelKey": "prap-2",

Then save the file as a new file, proteus-b-2.json . (Be careful not to overwrite proteus-b-1.json .)

Do the same thing with proteus-auto-1.json .


Thank you! Sorry, I missed it if it was already explained.

@marty I’m on macOS and actually I do have both installed at once - I just told the installer to put 2.4 in a separate folder. That seems to work OK, I can launch either 2.3 or 2.4. However I don’t really want to use 2.4 yet because of the lack of command line, so I’ll just stick with 2.3 for now. Hopefully with the 2.4 models added as per vic’s instructions.

right, sorry, missed the command line request ! hopefully, Vicullum8 gave you the right solution :wink: !

1 Like

Message for Mr Bishop or any other devs, i’m actually trying the Windows 11 last Iso insider release as main system (not in a VM), didn’t had any issue so far with anything I tried except 2 things (one is related to Magix vegas pro) i think, certainly software related.

just in case… the bug that was present in the 2.4.0 beta where the login was not keep after closing VEAI is back under this “beta” system, and using the 2.4.0 release. just saying , not a big issue, i understand it can be related to W11 but in case… as the system is out soon for Oem machine.

all the best :wink: !

Hi all

I’m still testing with Topaz and just realised I have a pretty major problem - the timecode of my source clips is not read or preserved! I tested both 2.3 and 2.4, and I have “experimental timecode” turned on.

With timecode turned on, in the app it shows all clips starting at 00:00:00:00.

This is going to make it impossible for me to conform the files written by Topaz back into my Resolve timelines.

Is this a known problem? I have tested two source input codecs: DNxHR and ProRes 422 HQ.

If I run ffprobe on the input files I am testing with Topaz, it clearly shows the timecode can be read by FFMpeg:

$ ffprobe
ffprobe version 4.4 Copyright (c) 2007-2021 the FFmpeg developers
  built with Apple clang version 12.0.5 (clang-1205.0.22.9)
  configuration: --prefix=/usr/local/Cellar/ffmpeg/4.4_2 --enable-shared --enable-pthreads --enable-version3 --cc=clang --host-cflags= --host-ldflags= --enable-ffplay --enable-gnutls --enable-gpl --enable-libaom --enable-libbluray --enable-libdav1d --enable-libmp3lame --enable-libopus --enable-librav1e --enable-librubberband --enable-libsnappy --enable-libsrt --enable-libtesseract --enable-libtheora --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libxvid --enable-lzma --enable-libfontconfig --enable-libfreetype --enable-frei0r --enable-libass --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libspeex --enable-libsoxr --enable-libzmq --enable-libzimg --disable-libjack --disable-indev=jack --enable-avresample --enable-videotoolbox
  libavutil      56. 70.100 / 56. 70.100
  libavcodec     58.134.100 / 58.134.100
  libavformat    58. 76.100 / 58. 76.100
  libavdevice    58. 13.100 / 58. 13.100
  libavfilter     7.110.100 /  7.110.100
  libavresample   4.  0.  0 /  4.  0.  0
  libswscale      5.  9.100 /  5.  9.100
  libswresample   3.  9.100 /  3.  9.100
  libpostproc    55.  9.100 / 55.  9.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '':
    major_brand     : qt
    minor_version   : 512
    compatible_brands: qt
    creation_time   : 2021-08-24T15:52:40.000000Z
    encoder         : Blackmagic Design DaVinci Resolve Studio
  Duration: 00:00:28.57, start: 0.000000, bitrate: 114038 kb/s
  Stream #0:0: Video: prores (HQ) (apch / 0x68637061), yuv422p10le(tv, bt709/bt709/unknown, progressive), 1280x720, 114037 kb/s, SAR 1:1 DAR 16:9, 30 fps, 30 tbr, 15360 tbn, 15360 tbc (default)
      creation_time   : 2021-08-24T15:52:40.000000Z
      handler_name    : VideoHandler
      vendor_id       : appl
      encoder         : Apple ProRes 422 HQ
      timecode        : 00:15:36:23
  Stream #0:1(eng): Data: none (tmcd / 0x64636D74), 0 kb/s
      creation_time   : 2021-08-24T15:52:40.000000Z
      handler_name    : TimeCodeHandler
      timecode        : 00:15:36:23
Unsupported codec with id 0 for input stream 1

Then this is ffprobe run on an output file produced by Topaz:

Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '':
    major_brand     : qt
    minor_version   : 512
    compatible_brands: qt
    encoder         : Lavf58.20.100
  Duration: 00:00:28.57, start: 0.033008, bitrate: 228859 kb/s
  Stream #0:0(eng): Video: prores (HQ) (apch / 0x68637061), yuv422p10le(tv), 1920x1080, 228859 kb/s, 30 fps, 30 tbr, 15360 tbn, 15360 tbc (default)
      handler_name    : VideoHandler
      vendor_id       : FFMP

No timecode at all!?

I don’t understand how this software can be usable in a professional context without preserving timecode. If I use it I will want to process several thousand clips and it’s vital that I can reconform them onto my original timelines. But that’s going to be impossible without timecode.

I’m hoping there’s something I’m missing and this can be made to work?

“I’m hoping there’s something I’m missing and this can be made to work?”

well it’s written experimental because it’s a feature which is … in his experimental state i’m afraid… so unless this feature is not anymore in alpha/beta… it’s like the use of both Gpu , it’s still experimental. but maybe someone else will come with a solution ;).

“I don’t understand how this software can be usable in a professional context”

Nobody never told that it was made for a professional use. i don’t remember any such statement from topaz in regard of this.

Thanks for the fast reply. I understand that it’s labelled experimental, but ‘experimental’ to me implies “works with some caveats”, however right now it seems like it doesn’t work at all. May as well not be there. That’s why I was hoping I was missing something, like it works with some input formats but not others or something like that.

Nobody never told that it was made for a professional use. i don’t remember any such statement from topaz in regard of this.

That’s… technically true. But on the website it says:

This makes it more cost-effective, faster, and better integrated into your workflow than server-based upscaling.

“cost-effective”, “better-integrated into your workflow”… these are terms you use for professional software. You don’t talk about integrated workflows and cost efficiency when selling software designed for your grandparents to edit their old VHS tapes :slight_smile:

Not to mention the price!

Anyway, I think I may have figured out a workaround. It’ll require more work on my part, but may be possible. Resolve has an option to output the source frame number on the rendered file. It’s meant for rendering to image sequences, but if you render a video file with it, the filename includes the frame number of the first frame. Eg in my last test: - so the first frame of the source clip is 28,103.

I should be able to write a script that uses that number to work out the starting timecode (based on the FPS) and then writes it into the file using ffmpeg. So I’d run that script on batches of files rendered by Topaz, before importing them into Resolve and then conforming.

I’ll do some testing on that.


can we get more focus on faster renders which is the most important


Found another problem that means my script idea can’t work when rendering MOV out of Topaz:

The FPS is somehow being set wrong on ProRes exports from VEAI. This means even if I use a script to set the correct starting timecode, the resulting file shows up in Resolve as having the wrong number of frames. It’s one or two out. So it still won’t conform.

Here’s ffprobe running on my input file:

Duration: 00:00:28.57, start: 0.000000, bitrate: 114038 kb/s
 Stream #0:0: Video: prores (HQ) (apch / 0x68637061), yuv422p10le(tv, bt709/bt709/iec61966-2-1, progressive), 1280x720, 114037 kb/s, SAR 1:1 DAR 16:9, 30 fps, 30 tbr, 15360 tbn, 15360 tbc (default)

And here’s ffprobe running on the ProRes output from Topaz:

Duration: 00:00:28.57, start: 0.033008, bitrate: 228593 kb/s
Stream #0:0(eng): Video: prores (HQ) (apch / 0x68637061), yuv422p10le(tv), 1920x1080, 228593 kb/s, 30 fps, 30 tbr, 15360 tbn, 15360 tbc (default)

Here’s the part that is wrong: start: 0.033008

This happens on every render I do from Topaz using either ‘ProRes 422 HQ (Fast)’ and ‘ProRes 4444 XQ (Slow)’ outputs. It happens with every input file I tested, including an input image sequence, so it can’t be related to input file metadata. Tested input files: DNxHR MOV, ProRes 422 HQ MOV, TIF 8bit image sequence.

These tests were done in 2.4.0 on macOS. I set “Show Timecode” to disabled, and I also disabled the Keep Audio option in case that might affect anything (though my test clips had no audio anyway.)

Looks like if I go ahead with Topaz I’ll have to render out in image sequence format. Of course this is going to use vastly more disk space.

PS. Another bug? Both the ‘ProRes 422 HQ’ and ‘ProRes 4444 XQ’ outputs in Topaz are producing 422 HQ files.

Quality is job 1 :grin:


I’ve been using the ProRes 422 HQ (Fast) output modes and it seems to mostly go okay unless the input file has variable framerate. When using Chronos though (and even when selecting Chronos once and later a different model) seems to completely mess with the duration of the file, a 1 minute file might end up 1 minute and 20 seconds if you ever selected Chronos in that session. I’m guessing it has to do with the slow motion variable or something.

Also worth noting is that Chronos seems to skip frames fairly often for me which ends up making the output look unsmooth which is kinda the opposite of what you’d want with Chronos.

Either way it would be nice to have this type of stuff a lot more reliable or it makes it hard to use the raw audio without re-encoding and so forth.

I noticed this as well. 16 bit TIFF is currently the only way to get high bit depth 4:4:4 out of VEAI, which is extremely wasteful compared to ProRes 4444. I always have this internal debate in my mind whether to go with 8 bit PNG or 16 bit TIFF, and then whether it’s going to fit within the disk space I have available, heh.

Also, not to sound like a broken record, but being able to chain models would save on processing time and disk space in general. A very common workflow for me is Gaia-HQ 100% to get crisp 4:4:4 chroma (Gaia is unbeaten at chroma upsampling) followed by one of the Artemis or Proteus models for the actual upscaling step.

Thanks very much for the details. I’ve never tried processing with Chronus but I think I clicked on it in the UI at one point. However I had definitely restarted (many times) since that happened.

To rule out any such problems I just did the following:

  • Uninstalled
  • Deleted every file in /Library and ~/Library related to Topaz - including all the caches and preferences etc
  • Reinstalled 2.4

Then I opened the UI, dragged my ProRes 422 HQ 1280x720 30 FPS (no audio) sample, selected 1920x1080p output, no grain, no audio, ProRes 422 HQ output, and filled in the suggestion boxes until it recommended Artemis MQ. Then I processed that.


Duration: 00:00:28.57, start: 0.033008, bitrate: 228583 kb/s
Stream #0:0(eng): Video: prores (HQ) (apch / 0x68637061), yuv422p10le(tv), 1920x1080, 228584 kb/s, 30 fps, 30 tbr, 15360 tbn, 15360 tbc (default)

Then I tested MP4 H264 output. Same thing.

Then I tested two more input files. Completely different source, different codecs (H264 MP4). And I got a very slightly different result:

  Duration: 00:00:13.37, start: 0.033000, bitrate: 45243 kb/s

0.000008 closer to correct this time!

Sigh. So it’s not related to Chronus it would appear. And I definitely don’t have variable frame rate encodes - especially given the problem happens even when I use an image file sequence as input, which of course has no frame rate at all.

So far as I can see, at least on macOS, Topaz simply always outputs video with a starting timecode of around 0.0033000 - 0.033008.

Maybe there’s some way I could script ffmpeg to fix the metadata, like I am hoping to add timecode. I’d need to investigate that. But when I tried, I couldn’t change the FPS without also reencoding the video.

Right now the only way I know I could use Topaz is to render out to file sequences. I have ~ 2 hours of 30 FPS footage (~ 216,000 frames) I would want to run through it, so that’s going to be a lot of disk space. Probably around 3 TB in fact. Though I guess I could write a script that monitors the output folders and encodes to a video format on the fly, deleting the image files as it goes. That should reduce the amount of free space that’s required at any given moment.

This is all quite frustrating. I was so impressed when I saw the picture from Topaz. But it’s proving such a hassle to actually use it for a real project.

My software is not working, like i open and after some seconds it just crash. anyone help? i uninstall and install, but nothing works

maybe we could help if it’s not VEAI related, but until then, i would suggest you to contact support and send them the logs when the crash happen. what does the windows even log tell when VEAI crash ? it’s an error related to VEAI or you have some other errors not related ?

1 Like