Video Enhance - Can I keep older versions active?

Hi guys - I am running 1.7.1 at moment without issues.
Do I need to uninstall this if I wish to try a newer upgrade?

No, of course not. You can still use the older versions!

what’ the difference in the two versions? Can’t find the thread

Here you find infos about different versions of any Topaz product: https://community.topazlabs.com/c/releases

cheers for that