Video Enhance AI v1.8.1

Both windows 10 1909 and 20h2 will work. In future 1909 support will be dropped, hence the warning.

I must apologize for my earlier response being incorrect. I said 720x576 to 1920x1080 would use 200%, but that is not true. The program is upscaling 267%, which would use 400%, not 200%. So I used a test copy of 720x576, and using Artemis V9 an upscale of 200% was 0.09 seconds per frame, while an upscale to 1920x1080 was 0.26 seconds per frame.

That leaves me without an answer for your “same speed” for 720x576 with 200% and with 1920x1080. Can you run your test again to verify the speeds?

How much TBW does it have that you worry about? (TBW = Total Bytes to be written)

The previous version I had (don’t remember which one off the top of my head) would mix in the audio automatically, this one says it can’t work with surround sound. I have the original ripped uncompressed video, but I have no idea how to get the surround sound tracks from it to the file that VE outputs. I’ve tried searching for guides on it but I’m not 100% clear on the terminology I need to search with so I haven’t found much. I have both windows and Linux available to me for this. Just point me in the right direction (a step by step guide would be awesome). Thanks!

Only Topaz could properly answer that, but they’ll probably ask you to upgrade to a faster system before they do any investigation.

Actually it was designed to work with noisy sources. And I relied on that feature to clean up “Lucky Girl”.
Lucky Girl (2001) 480i to 720p upscale

See the samples linked. Huge difference in noise levels (and detail).

I have a Lily Allen gig I’m releasing soon that ArtemisMQv9 was able remove the noise and leave (relatively) clean video.

Did you see the ArtemisMQv9 vs. GaiaCG 1.6.1 samples I posted? This is with very clean video. It clearly shows the GaiaCG 1.6.1 raindrop artifacts. I’ve seen them before, but not as bad as this video has them.
Here’s the link again:
~418MB
https://mega.nz/file/s9FhDQ4Z#U-9HP_n8w8nzcpzTQJhZrwv2XkT64Hp-pzKff2SGPKY

It took a day to sort out the mess that Avisynth+ is (4 plugin folders…), but now I have 64 bit Virtualdub2 running 64bit Avisynth plugins on this box. I’m encoding a video with x264 at 8.6fps with 100% CPU utilization. The best I’d seen with 32bit on this box was 2.6fps (at 30% CPU). So yeah, 64bit has hugely improved CPU utilization and fps. It’s using 175W and at ~76C.

TBW is a useless measure unless you live in a lab with controled temps, never turn your PC off and use your SSD for ‘burst’ periods of time a day.

Does someone know what error C means when trying to export a prores file from the image sequence (png from VEAI) with Avisynth in HYBRID?

The crash reports from both the GUI and attempting the same from the CLI are giving a segmentation error so it may just be a bug… so we have submitted it to Topaz. They are generally very responsive :slight_smile: Thank you for your advice, when we get back to using a more powerful Mac there will definitely be less issues.

1 Like

For those out there with a decent GPU :slight_smile: does anyone have any benchmarks for conversion speed for the native upscaling compared to the native and the lanczos resizing?

As previous posters have advised that e.g. a 191% upscale is done as a native 200% upscale followed by a lanczos downscale to 191% or for example a 300% upscale being done as a 400% native upscale followed by a lanczos downscale to 300%

I was wondering if it could be faster to do the upscale to a native multiplier such as 200 or 400% and then work with that in my NLE etc going forward and downscaling back to the final desired resolution at the point of mastering my output. That would give more resolution to use during the edit.

Basically I’m wondering if the lanczos additional step in VEAI adds to the processing time per frame and could be avoided by working in multiples of the native resolutions?..

Need help with my workflow still didn’t fix my problem of the gamma shift with mp4 > png output from VEAI.

This is my workflow (which doesn’t work yet)

  1. Upscale in VEAI 1080p > UHD and create an image sequence PNG (this files have a gamma shift which I want to fix to ‘original 1080p master look’ (input is Canon dslr 1080p rec 709 footage)

  2. Open Hybrid Selur

  3. Create image sequence with first and last frame of the upscaled PNG files. (luma range: TV and color matrix bt470bg, someone told to use this to combat the shift)

  4. Output Prores 422 HQ

  5. Avisynth filter gamma > 1,02 (this should fix the gamma shift?)

  6. Avisynth custom code ConvertToYV12(matrix=“Rec601”)

I can’t get any file out of hybrid it gives me this error
p, li { white-space: pre-wrap; }
-> 2020-12-26@14_08_53_8910_02_video crashed: ERROR: C:\Users\rick\Desktop\test ve\test v2_2020-12-26@14_08_53_8910_02.mov was not created!

Aborting ‘2020-12-26@14_08_53_8910_02_video’ due to: ERROR: C:\Users\rick\Desktop\test ve\test v2_2020-12-26@14_08_53_8910_02.mov was not created!

How can I fix this hybrid issue. Or even more preferable how to fix all this issues just inside VEAI.

With an i9-9900 and 2080ti I am unable to see a measurable difference in speed between a 400% and a 267% upscale. The difference may be there, but very small.

That said, I’ve taken to doing the resize afterwards, using spline64 rather than lanczos for quality reasons. That of course does add time to the project.

1 Like

You better use Avisynth+ & VirtualDub2 directly and try a script like this

ImageSource("%06d.png", start=0, end=10000, fps=29.97)
ConvertToYV16(matrix="Rec601")
Levels(0, 1.02, 255, 0, 255)

replace the end number by your last png number file and fps according to your video.
But I have tried a direct HD YUV file with v 1.8 and didn’t noticed any gamma shift, just the color shift.
Play with the gamma until you think it matches your source. May not necessary be 1.02.
VirtualDub2 can encode ProRes and then the right YUV conversion for planar 4:2:2 chroma subsampling is ConvertToYV16 and not ConvertToYV12 that is 4:2:0 for end user consumer video level (H264/265 encoding)

1 Like

I still don’t know what you worry about.

then you should just don’t say anything, thx

Hello noob here.

For output does the setting I choose affect quality, if so which is the best? (mp4,mov,tiff,png)

Also what point does CRF become lossless for let’s say 4k?

I’ll answer the last one: CRF 0 is lossless in h.264, which VEAI is using for MP4.

I’ve heard people say there’s a point that the human eye can’t tell the difference, so 0 crf is a waste, thoughts?

Also is exporting to PNG be the same as 0 crf mp4 since it says lossless?