Video enhance AI 3.0.12 & 3.1.0 Stabilization bug

A couple of post down below is a accurate description of the problem after lots of testing

Had the same issue on 2 completely separate systems.
One platform w10 with a rtx a4000, the other with w11 equipped with a rtx 6000.
No matter what file format goes in or out the image is just this strange blank field.
Attached screenshot.
When running preview it processes correctly, but when exporting it does not.
All drivers and things are updated to most recent.

2023-01-17-21-14-58-Main.tzlog (418.9 KB)

Also present in the Beta

1 Like

Is this something you only experienced with 3.0.12 version and beta version or did you had the same problem before with other versions of the program on the same systems?

have not previously used the stabilisation function before. But have never got this result with the upscaling.

I see. I assume its a bug. Hope they fix it soon. Just curious. Is this file straight out of camera, and may I ask which camera was used? Thanks.

Its just some random gopro footage of a customer who builds roads and cycle paths, was already existing footage and the question was if we could improve the footage some or if new footage needed to be shot, file is just MP4. But i am a bit further in my investigation.
1 - since preview worked fine i did a CLI export with the duration changed to the entire duration of the clip instead of the max 15 sec, this failed to my disappointment.

after further testing it seems that when exporting part of the clip goes oke… but not the whole clip so im currently trying to find the exact breaking point, its at around 2 minutes or so. I do not yet know if this will be repeating every 2 minutes or if its just the one point that breaks it.

It is very strange because one of the first things i tried was to transcode the clip to make sure it wasnt anything in the clip that caused the problem.
I had even make a PNG sequence of the clip to test it. So cant be something in the technical frame side that is giving problems. Maybe a strange artifact from something that goes out of bound for the stabilization or something, if its a one place occurrence or regular repeating should answer that question i think

Was able to reproduce the same bug on amd and intel gpu’s and cpu only mode with this specific clip.
Solution was to cut it in sections no longer that around 2 minutes, solved the problem.
Very strange indeed…

1 Like

Oke so i have sort of found the specific issue but has some variables about where it appears.
It happens with Full frame stabilization and as the video goes along it can get into wild swings when it overshoots its correction.

Now this does not happen if you start rendering shortly before the heavy movement, so it never happens in preview. It also never happens if the clip is shorter than a minute or so. Its something that gets build up with 1,5 minutes of footage and then gets triggered by a place where a lot of motion compensation needs to be done and it just looks like after some wild oscillations it just flips out of the universe. :smiling_face_with_tear:

So definitively a bug in the software and not the footage


I’m having the identical problem! I thought it might have been due to the extreme shake and soft focus in the video so I de-shaked it in Vegas Pro 19 which did a barely OK job, but not anywhere near the great job Video Enhance AI can do. I’d still prefer to do it in Video Enhance AI if they can fix it.

if the project is important enough you can do it currently but its a pain in the ass.
If you cut the video up in sections of about 1.30 min and make sure you have 10 sec overlap at both sides then you can render the individual parts and then sort of blend them together after. but its no fun and very long process. :sweat:

The longer the video runs the more it seems the AI will try to pre empt the movements to a point that this is enough to make it go in oscillation.

If you don’t mind me asking was you’re video also really fisheye distorted like mine? (gopro like footage)?
I was thinking maybe because there are very little straight lines cause of the warping the AI gets confused in referencing whats happening

My files are from super8 film that has been scanned with a Moviestuff Retro 8 to a 1000x720 image sequence which is then output from Vegas to an mp4 video file. There’s no optical distortion such as fisheye, but there is a lot of frame instability due to the movie camera being zoomed and hand-held. The focus was soft due to the tiny film frames and the B&H optics which also have a bit of colour fringeing. I’ve processed a few still frames with a Gigapixel demo version and they clean up fairly well except for scratches and dirt which I can remove 99% with NEAT Video for Vegas.

I checked if the stabilization would be more stable with first removing the fisheye lens distortion but result was the same so it really seems independent of the footage. I would have guessed this would come up in development sooner. Only thing i can now think of that maybe because its continues moving footage.