Video Enhance AI 1.7.1 isn't working

Depending on which model I choose, either nothing happens, or the program crashes.

Peeking in the log shows these errors:

2020-12-08T10:01:13.005 [Debug ] proc ERROR!!! --PROCERROR:ENGINEFAIL 2147483647

2020-12-08T09:59:55.192 [Error ] < line #: 0> Thread ID: 0x200921af410 Loading default error reading file: C:/Users/Anonymous/AppData/Roaming/Topaz Labs LLC/Video Enhance AI/models/ahq-v8-fnet-fp32-480x384-2x-ox.tz

2020-12-08T09:56:05.308 [Error ] < line #: 0> Thread ID: 0x200928fff90 Image Model inference failed: unable to run model with index 0

Could it be your system? 1.7.1 needs Windows 10, v 2004 recommended.

That is the version of Windows I have. It should be the most up to date version, since I let Microsoft update it automatically.

I also updated my Nvidia driver. That didn’t help, either.

I have the same issue and log complaints. Enabling “Do not Download Fast Models” fixes it half way for me. Artemis HQ v8/LQ v8, Theia Detail/Fidelity begins working as it should, whereas any of the other models either give a blank image or crash the application. Both Gaia models work when process by the CPU. Artemis ASQ v9/HQ9 v9/AA v9/LQ9 v9 doesn’t work whether processed by the CPU or GPU.

This is an odd one. The V9 models were apparently included in an accidental release under the 1.7.1 numbering. They weren’t ready. The original 1.7.1 did not have V9, and at least yesterday they were removed from the 1.7.1 download. How long the download had the V9 I don’t know, but they aren’t going to work. You can re-download the 1.7.1 and replace the one you have, or just ignore the V9 models for now.

2 Likes

Well, that was an easy fix. Thanks! Only proper models are now visible and previewing worked straight out of the box, no need to tick any boxes. Also every model can be run on the GPU.

I’m glad you mentioned the models you were using - we see a lot of “it doesn’t work” posts, but yours was the first here I saw mention that they were having problems with V9, so I had an ah-hah moment!

Oh, man. That was it! I re-downloaded 1.7.1, and suddenly there’s a lot fewer models. And it works! Thanks!

Glad to hear it! I think the V9 models will be available soon, but they weren’t ready when that version got accidentally uploaded.

hey deelmgGuy, is there a way of knowing when it’s “Safe” to turn off internet connection for Topaz? is there a confirmation that all or all needed models are downloaded? Windows Updates messed with one of my jobs last night, and i’d like to be able to disable internet to my machine so it doesn’t auto-update, and then do that part manually when necessary, but i need to know that Topaz has the models it will need to work before i do that. any suggestions?

It is generally safe to turn off the internet for VEAI, except every so often it appears to need to validate your license, in which case you get a never-ending initializing screen. If the models haven’t been downloaded it works its way down to the next best, then the next, and so on until it hits the 288x288 that came with the install. That doesn’t cause problems, just a slower processing.

I run without Topaz having an internet connection most of the time, but I choose to download every model when each version comes along. I posted how I do it in the 1.7.0 thread, but I probably should create a separate thread.

It is important to note that the installers now do a full uninstall and wipe out the models folder, so I maintain a backup that I can copy in after a new version is installed.

just saw your tutorial post and i’ll give that a whirl over the weekend. thanks for the insight and info!