VEAI - processes for about 10 seconds, then stops - no explanation why

First of all, just FYI, I have to run all my Topaz software on the CPU, because almost all the apps crash my AMD RX580 video card (no matter what driver I try)

Anyway my issue is this:

I import a 10-second-ish video, select a couple options, click EXPORT, and nothing happens for a few seconds.

THEN the CPU kicks in for about 10 seconds (with no status bar (estimated time left?) in the program?), then the CPU stops - the program then just sits there, apparently still working (hasn’t crashed), but does nothing more.

What gives?


Just downloaded the trial version. Windows 10, AMD Ryzen 9 3900X, AMD RX580, 4GB.

1 Like

I’ve seen that happen when running out of VRAM (I’m using a RTX3080Ti w/12Gb). Not sure why it would happen on CPU processing. Take a look at memory consumption when it happens…maybe there’s an allocation bug.

Thanks for the reply.

So I tried again, and it turns out that only if I click on PREVIEWS (right next to “All Outputs”), does the preview “bar” pop up in the OUTPUT box (swear I had tried that, but maybe not).

And then to see the side-by-side comparison, I have to click somewhere in the preview “bar”, but maybe that’s normal. (I would have thought clicking the blue “Preview” button at the lower right corner of the main screen, would automatically split the screen in two).

I reported the exact same issue, yesterday (hadn’t found your post yet). And I have a GTX 3080 Ti as well.

Something is off. Could be a memory issue (default set to use 90%, iirc), as VEAI doesn’t seem to stop when its not in the foreground (aka, when it doesn’t need to spend resources on preview windows).

All-in-all, wish they’d had some more testing on 3.03 (I came from 2.64). The new one is far worse than the older one.

I am having the same issue

5950x, 64gb ram, and a 3090.
Using the demo version
From 720p@24fps to 4k@60fps present

I cropped the input to 3 minutes, I run the processing and it estimates 30 minutes ish. It stops after 1 min 30 seconds consistently, only outputting around 8 seconds of upscaled video.

Is there any fix?

Could I take a look at the app’s log files to see what is causing the error in Video AI?

To gather logs, please select Help > Logging and make sure that there is a check mark next to File Logging. Next, recreate the issue and then return to the Help menu and select > Get Logs for Support and attach the “logsForSupport.tar.gz” file to your reply.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.