VEAI / Kasperky blocking connection

I have been using VEAI for about 2 years, running the latest version (2.6.3) since available, but all of a sudden Kaspersky Total Security is not allowing it to connect to the internet, which brings its own issues.

Now I can disable the AV program and its fine, and I have been using that (Kaspersky) for many years and ‘think’ I know my way around it at least a little bit. I have tried adding the topaz exe to trusted apps, but not having any joy. I cant see anything in the reports that says its blocking the app, so a bit lost to be honest.
Just curious if anyone else has experienced this recently.

It may well be your internet provider is blocking Kaspersky because it is a Russian application.

1 Like

The thought crossed my mind, initially that maybe the topaz servers were somewhere that was affected.
As for isp blocking, I doubt it. I have a lot of software that requires connection and this is the only one that seems to be affected.

I can work around it by just disengaging the AV on startup and then enabling it again but it never was an issue.
Definitely Kaspersky that is affecting it, I must be missing a trick

1 Like

I have Kaspersky Internet Security and no problems, although I do not use VEAI but SAI, DAI, GAI. In Kaspersky, go to Settings - Protection - Firewall - Application rules. You can check there what is blocked in your system and modify as needed.

Also, at least for KIS, I do not need to “disengage on startup”; any moment via right mouse on program icon in system tray gives the option to exit from KIS. I guess the same should work for KTS.

1 Like

Same here re. my Kaspersky I.S., no issues at all when using VEAI … or anything else. Haven’t yet decided whether or not to dump KIS on expiry, I might.

I also have Topaz SAI, DAI, GAI software and they are connecting just fine with no issues.
It’s just VEAI that is the issue, just lately.

I have uninstalled VEAI and installed an older version with the same result and then reverted again to the latest version.

In Jan i renewed my subscription to Kaspersky for 2 years. My last resort is to uninstall the AV software and do a fresh instal of that to see if it works.
I cannot see anything that is blocking it in the Firewall or Application rules.