VEAI choppy 4k mp4 output

Again: cannot create directly to VEAI section.

I’ve got 23.976 fps 1080p material, which flows smoothly on pc/ps4/lgtv.

Then when I converted it with VEAI to 4K, I got constant frame-skip-like-effect exactly with one-second intervals like clockwork. So the image pauses just a little and then rushes forward, effectively spoiling the movie.

Results tested with usual suspects: pc/ps4/lgtv so no codec issue.

I tried to google this but no clear way forward. Has anyone else experienced the same behaviour with converting 23.976 movies? Please, does anyone know some trick that would make this mp4 file play smoothly?

Hi and thanks for writing in. Have you tried re-encoding using Handbrake? I have found that re-encoding prior to running through Video Enhance AI fixes the choppy playback

That should not be a solution, because you would degrade the quality further before scaling. But I will test this.


Re-encoding was not needed: simply put the file through MKVToolNIX which basically makes the following change, mp4 → mkv.

Then rerun this mkv file with VEAI and voila, it worked, no more choppiness.

As a suggestion, you might look into why this is happening in the first place.

1 Like