VEAI 3.1.0 closes/crashes at end of export

I have had two cases of finding that VEAI has closed by itself at the end of export. This is not something the app has done in the past, and I have been using VEAI v3 since its original release.
Another observation is that the exported file exists in the same directory with a .temp version which usually isn’t there after the export is completed. It is like something goes wrong right at the very end of the export process.
Is anyone else experiencing this? I use an M1 Pro 16" Macbook Pro (Mac OS 12.6.2). I will turn on detailed logging now in case it happens again. Thanks

1 Like

Got the same problem on Windows. Tried exporting multiple files and VEAI will crash when trying to finish the first file. And when I tried to delete the temp file, it just stalled the whole PC. I only got this problem after updating to v3.1.1. I’m guessing the new setting in the video export option might cause it. I’m downgrading back to 3.1.0 to see any difference.

Mac Mini M1 here. I’ve found it only seems to crash when I’m exporting ProRes. Switched to H.264 High and no crashing. Not an ideal solution, but an interesting discovery.

1 Like

Some similarities here. If I export two files, it will crash at the end of the last file just like @anthonytran2911

I am also exporting using Pro Res 422LT @mark.strube

Crashing on 3.1.1 too

Have exactly the same issue here Pro Res 422LT fails to produce a complete video file ive noticed that it seems to crash as its producing the finished file from the temp file i often find the temp file is 220gb in size but the attempted complete file is say 190 gb i even had a crash which shut my pc down and when it rebooted it said the bios was reset , ive reinstalled windows 11 and left it producing a file over night last night and when i went to the pc in the morning windows was at the log in page so it had obviously crashed and rebooted again , im rolling back to 3.1.0 to see if this helps but seems to be a issue with exporting to Pro Res 422LT

@pjfalzon81
update: I seem to temporally fix the problem on version 3.1.1. Just go to Preference → Output → Change the Video export setting to “Without Preview”. This wouldn’t create the temp files anymore, and VEAI won’t crash at the end. Seem like VEAI having some glitch trying to delete the temp file once it’s finished.
Note: the export files are perfectly fine, you won’t be able to preview the export (while rendering) in VEAI though.

1 Like

@anthonytran2911 thanks for the tip. I’ll give it a try. I actually prefer to process without a preview so this works well for me.

Does anyone know what happened to my Advanced Settings menu in preferences? It’s no longer there so I cannot turn off Advanced Logging.

@pjfalzon81 Yeah press Help → Logging. Press the logging button so that it doesn’t show the dot next to it anymore.
image