V3 a lot slower on same hardware?

Hi,

I’ve installed 3 on the same system but it’s processing 1080P movs upscaled to 4K a lot slower than version 2 (about 2.6 fps vs .57 fps on v2)

I’m just using a single 3080, using 522.30 drivers, and tried maximising the memory usage

Is there some secret setting to at least match the performance of the older version?

Thanks,

Steve

2 Likes

For me, one of the most annoying things in 3.0.0.2 is always ‘downloading mod’, this takes enormous time even with my 1GB connection!

Topaz: WHY is this not integrated like in V.2.6.4?

2 Likes

Its at least 3 times slower. Converting my first movie with it and its now running for 3 days an a MacMini M1 16gig.
Maybe the quality is better, but I cant tell yet.

2 Likes

I can’t see much difference - but I haven’t tried it a lot because it is so much slower

It would have to be a lot better (or I needed the other features like stabilisation) to justify using it

Artemis HQ 2x upscale from 720p to 1440p is about 20% slower on v3 (using 5950 and 4090). Not sure what the reason is.

1 Like

Tried now several longer movies, each takes >24h to finish, so same as with V2x. All 4k upscales
Only 1 had this 3x time issue (5days runtime). I did not double the frame rate, this takes so much extra time.
Will try different setting to see what was the cause

Slow render times are likely caused by high memory use here. 1.85gig swap use.
MacMini M1 16gig Ram
So16gig are no longer enough for a 4k upscale. I knew that 4k requires more Ram, but it looks like it uses even more Ram now.

V3 runs on my Intel iMac which has 40gig Ram

Windows PC here with 64Gig, the PC is old, but the gfx card is new - and the previous 2.x performed a lot better

So not sure it can be a memory issue in my case

V3.03 caused slowdowns. I use 2 systems, 1 has a single 6900xt and the other has 2 1080TI’s, they both run some models slower than the previous release of V3. The 6900xt got hit really hard, it’s slower than a single 1080TI on some models.

Since this just popped up I assume it can be fixed.

Converting 4k to 4k, so no upscaling but a lot of denoise/sharpen/details.
That takes time, would say at least 2 times longer.
New MacBook Air M2 with 24gig Ram, compared to MacMini M1 16gig
As long as it works and stops crashing I accept the long render times is quality justifies it.
But over 3 days for a 100min movie is very long.

i9 12900k here, 64G memory, and a RTX 3080 Ti.

I haven’t used a full-length movie yet with 3.0.3, just a few 45min 1080p episodes, to be upscaled to 4k, which take around 10 hours a piece (at ca. 2.2 fps), using Proteus fine-tune. I think this is about on par with the 2.64 version. All P-Cores are perfectly saturated, btw (keeping all E-Cores parked).

What take ridiculously long, though, is that odd 2nd pass, where it writes a .prob3 file (on using ProRes 422 HD). My output disk is not a SSD (I don’t feel like writing terabytes of data to a SDD, on a frequent basis), but still a fast SATA3 disk. So, VEAI seems to work thru a >406 GB file, to create this 2nd pass file (which takes over an hour too). Can someone tell me the nature of this file? And whether I need it. It’s a PITA, waiting for it to complete.

ProRes is not GPU accelerated and takes very long to encode. It’s not related to HDD vs SSD I think (u can have a look in Windows task manager and see what your disk usage is).

What is, though? I’m sure .TIFF isn’t GPU-accelerated either. HEVC may be (with an nVidia card, but its implementation is crappy, and meant for fast-over-quality). Same for H264. Besides, H265/H264 are extremely computational themselves.

And what’s there to encode anyway, to ProRes? The encoding part, as I understand it, is the calculations VEAI does upscaling the image: the rest is just writing to disk (ProRes format).

If you know of a faster output, though, please enlighten me (no, seriously). A full HEVC encoding (on 4K), with x265 alone, goes at ca. 5.5 fps. Considering VEAI has to actually be intelligent as well, personally I thought ~2.2 fps isn’t all that bad.

If using a Mac with M1 Pro or M1 Max – they all have hardware accelerated encoding and decoding of h.264, HEVC and ProRes files.

The Mac M1 has hardware accelerated encoding for h.265, HEVC and just decoding or ProRes files.

3.04 is more stable, so I had the chance to actually use it. I just encoded the same movie I did before with 2.x, same time (30h). Its not slower when using the same settings.
More denoise and other things affect render time badly, but the result is worth it.
Lowered memory use so the is no swap use.
There are still many issues with 3.x, but mostly UI related

I am definitely not seeing any performance gains with V3 when running parallel processes (as some have indicated). The software shows that I am, but the estimated time to completion is not consistent and the seconds per frame indicator is based on some unknown average over a certain period of time I guess (it is usually off by 20%).

I use a separate timer to clock the actual time required to process a video – there is a big difference in completion time.

I am starting to wonder if this is the case with V2.6.4 now.