V3.2.4 doesn't enhance the first x number of frames

It seems to differ. Sometimes it’ll do the whole file, and sometimes it’ll show a freezed frame for 6 frames or maybe more than a second.
This is utterly useless.
(and is only one of about a million things wrong with this program. I miss the old program, it just worked)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

This is odd and is not a known issue, can you please share a screen recording?

Oftentimes it is easiest to share a screen recording for issues like this to quickly show me exactly what is happening. I use Loom for screen recordings since this is a free and easy to use app.

Hi there, is this still occurring?

Hello again, Ida.
I have been off for some time, but have continued using Topaz Video AI.
I have compiled a list of issues and errors, as well as a few videos. The issues and errors vary in severity.
The list is up to date with the 3.3.2 version:

ISSUES AND PROBLEMS (I use a Windows computer)
Full screen mode will sometimes locate itself above or under the windows taskbar. Both of which are annoying for different reasons. But it won’t always do this, just sometimes. This honestly seems to be less prevalent in the 3.3.2 version, but it’s still there at times.
Screen recording of issue: https://www.vilaverfilm.dk/Extra/Topaz/Scrubbing%20through%20video%20and%20program%20over%20taskbar.mp4

Why is it not possible to open the same file twice? Maybe I wanna render out two different trims of the same file.

When exporting more than one file simultaneously, all but one or two files will encounter an error. Maybe I don’t have a graphics card that’s good enough, and that’s completely fine, but why is there not an option to cue up multiple files at a time, so that you can cue up twenty files and go to bed, and then once the first file is done rendering, the next file will start, rather than the program trying to start all twenty files at the same time! Starting all the files at the same time seems especially useless, since the renders will be slower and thus take the same amount of time (and sometimes more) than if the files had been rendered one at a time. I would like the option to cue the files.
Screen recording of issue: https://www.vilaverfilm.dk/Extra/Topaz/Rendering%20multiple%20files.mp4 (you only need to watch the first half of the video)

Also, if you ask it to render several files at once, and you have set different parameters for each files, it will change the parameters of all the files to be the same! Super annoying.

I can never be sure that the first second (circa) of the exported Topaz file will actually function properly. Sometimes the first second of a render is a freeze frame, sometimes it time jumps a little, and sometimes there’ll be freeze frames here and there. To be fair though, this only seems to happen when I’ve trimmed a video, so it hasn’t affected full length files that I’ve needed to do something to.

The program always starts on the same preset. Why doesn’t it simply remember my last preset, or at least give me the option to save a preset or something. I often have to render out files with the exact same settings, but I’ll have to plug them in every time I open the program.

When in full screen mode, I am still able to grab on to the edges of the program and move it. This shouldn’t be possible of a program that is in full screen mode. It is especially annoying when trying to grab onto the scrollbar to the right, seeing as I’ll often grab the edge of the program instead and accidentally resize the program. The side scrollbar is also quite small, so it’s not the easiest to grab onto when you have to be pixel perfect with the curser, unlike every other program in existance where you are allowed to move your curser all the way to the right when in full screen mode (example: Any internet browser when visiting a website where you can scroll down).
Screen recording of issue: https://www.vilaverfilm.dk/Extra/Topaz/Full%20screen%20mode%20dragged%20still%20insists%20its%20fullscreen.mp4

And why even am I able move the program window when it’s in full screen mode? Sure, you can do this too with other window-mode programs like for instance with browsers, but there you at least have some leeway when grabbing and dragging. If you grab at the top of Chrome and move the curser, you have to drag it for some distane before the window minimizes and moves, but with Topaz, it moves straight away. One pixel of movement is all it takes.

Oh and adding to the above problem, it doesn’t change its state to be minimized, it stays the same size and the icon at the top right corner even insists that it is still full screen. Then when clicking that icon it doesn’t realize I’ve moved it or even resized it, and then minimizes to some other size, before I am then able to click the full screen mode button again.

  • And by “minimizing” I mean the opposite of maximizing. I think its technical term is “restoring”.

When trimming, it seems to have especially a hard time when moving the in and out times backwards. It sometimes previews that you are somewhere (several seconds ahead or past) where you are not. in the 3.3.2 version this is not as bad as it used to be, but it still jumps around quite often.
Screen recording of issue: https://www.vilaverfilm.dk/Extra/Topaz/Scrubbing%20through%20video%20and%20program%20over%20taskbar.mp4

#T2 (this one is new to the 3.3.2 version, at least since I upgraded from the 3.3.0 version I believe it was)
When trimming clips, Topaz now sometimes insists that my 25fps video is 50fps, though it does show a jump of two frames in the timer for every frame moved (which makes sense as there are only 25 fps, but it will then show frame 0 as frame 0, but show frame 1 as frame 2 etc.)

As I have upgraded to newer versions, I have seen some issues fixed and thus I have removed them from my list, but there are still quite a few major problems plaguing the program, and some inconveniences which make the program difficult to use.
I am happy to see that you do in fact fix bugs, but I am still longing a bit for the original Topaz Video Enhancer program, which honestly seemed to have none of these issues.



  1. I am a bit unclear on this one. Is the issue that the icon sometimes does not appear in the taskbar? I do not believe that this is a TVAI-specific issue. Here is a link to a Windows 11 article on this issue.

  2. Yes, this has been brought up in development since this was something that could be done in v2.6.4. I will ask our team again :slight_smile:

  3. You would change the max processes to 1, this would process one file at a time until the entire queue is complete. If a processing error is encountered this may disrupt the entire queue depending on what the error is. If you would like to share your logs, I can take a look.

3b. This is not expected behavior unless you select multiple files and then choose settings. The video settings will remain unique when processing more than one file at a time.

  1. Can you share a screen recording?

  2. The settings are not sticky, but you can choose the desired settings you wish to start with under the File > Preferences menu.

  3. On your Windows 11 Desktop, right-click and select Display settings. In the pop-up display settings window, ensure the Scale and layout is set to 100% . Under the Resolution section, change to the proper resolution to make your monitor full screen.

T1. This does not seem problematic, it just seems to be catching up- although this does not happen on my end (mac) and way be specific to the speed of your machine. If you are working with a very low-res file, does this still occur?

T2. Are these files interlaced?

1: This doesn’t seem to be the same problem as that of the link you sent me, also it only happens with Topaz AI, no other program has ever caused this issue for me, but regularly happens with Topaz AI. It’s not the worst problem ever, just really annoying.

2: Great.

3: Cool.

3b: Well, expected or not, that’s what it does.
I can, however, click export separately on every file and then the problem doesn’t occur.

4: I may have time to do so later, but not right now.

5: Okay.

6: My computer was already set to these specifications. Having just changed the settings and reset them, the problem still occurs.
100% - 1920x1080 (Recommended) - Landscape
(My monitor is fullHD, not 4k or anything)

T1: It is not catching up, it displays the wrong frames and jumps around. That is not the same as catching up. Sometimes its very bad, sometimes there’s nothing. Doesn’t happen in any other program, HOWEVER, it IS reminiscent of scrubbing through files recorded on Apple products on a PC (say, in Premiere), hmm, could it be a codec problem?

T2: Well, the files show progressive, but these files specifically were filmed with a thirteen year old camera at a “jailbroken” setting, so maybe it thinks its interlace. Which would explain why other files do not act this way.

N1: Past topaz AI versions wouldn’t allow certain files to be placed into the program, it would insist it did not have the correct codec. Fair enough. Current (3.3.2) version DOES allow these files now, great, however, it outputs the files in a different codec than other files.
Example: File A and File B. File A used to not work with Topaz, but now it does. File B always worked with topaz (so they both work with topaz now). File A and File B (different types of files though both mp4) are put into topaz and rendered out with the exact same setting. But New File B is accepted into premiere, while New File A is not (premiere pointing to the different codec as the problem).
Bonus knowledge, both the original File A and File B could be placed into Premiere. It is only the topaz rendered File A that isn’t allowed.
I don’t know how rendering/programming codecs work, but it would be great if files were saved as the exact same file type, when the settings are the exact same in topaz.

N2: Topaz AI 3.3.2 now delivers these weird blobs sometimes
https://www.vilaverfilm.dk/Extra/Topaz/WeirdBlobs.mp4 (look at the ending)

Please go ahead and create a support ticket so that we can work on these issues independently. This conversation has moved beyond the original bug posted.