Using x264 crf mode in 3.x versions?

As the topic says
I cant seem to find the option
was it deliberately removed?
Can I add it back through encoders.json?
And on an additional note does anyone know how to do lossless encoding(I mean actually lossless not near lossless like prores) without x264 crf encoding?

1 Like

Please search this forum. We have lost count the amount of times this question has been asked.

1 Like

I did
All it did was direct me to old 2.x version posts


Search for what you’re looking for: Where is CRF in TVAI.

I’m also looking for the x264 encoder
And seems like both things arent possible?
libx264 is not enabled since topaz didnt buy the license probably
and crf isnt really the same with cqp on hwenc


Here’s a present for you, if you really want libx264 lossless and willing to do some faffing around:

You would need to change my example -vb 8000k to something like -preset ultrafast -qp 0



Oh I was not aware we could directly edit the ffmpeg
Do I do it inside TVAI or do I need to execute this command myself?d

You can open the command line with the process menu on the top. Then you can right click on the job you’re processing, and click FFmpeg command, and copy it from there. I like to change it up in a text editor, then paste it into the command line.
Set everything up how you want it to run with the models and everything. Hit export. Then cancel it. Then modify the command and all that.

You don’t even need to Export and abort. Set everything up how you want it to run with the models, then go to Process → Show Export Command (CtrL-Shift-E).


Nice thanks to you both
@ForSerious @meimeiriver

1 Like

Actually, indeed, using -qp 0 is the preferred way over using crf 0. Few people seem to know that. :slight_smile:

Actually, you can’t. But it really would be nice if we could. Just to be able to edit the command line that TVAI is about it deploy, then start the Export, and keep using the UI with Preview and all. In fact, at first I thought that’s how it would work.

Oh. I always export to png. Hitting Export creates the folders. If you don’t create them, the command fails.

Ah, I see. :slight_smile:

Well uh
Your method did work with some tweaking
However while it produces a video
It only produces it for the first 2~3 seconds or so then the pipe ends like it had ended properly
No errors or anything

And now for whatever reason it’s doing this

av_interleaved_write_frame(): Invalid argument
Error muxing a packet for output file #0
Error writing trailer of pipe:1: Invalid argument

Seems like a faulty pipe?

I am no ffmpeg expert by any stretch of the imaginmation, but I don’t think you can just use rawvideo without giving the process some ‘manual’ assistence re framerate, resolution, format, etc.

In your tweaking, did you accidentally miss out the single dash in the 2nd ffmpeg?

(You can add -y if you just want to overwrite an existing file without a separate “already exists” error.)


The first and last time I’ve tried to output to Png I’ve set the command to output to a already created folder and it worked without problems… -pix_fmt rgb48be -start_number 0 C:\foldername%06d.png