Upscaling control issue

Good morning. I am having a problem with the upscaling function in 2.4.1 (running on a M Macbook Pro, 16 GB,IOS 11.6.8 Bug Sur) . I let the autopilot function run which works fine. I then attempt to actuate the upscaling function. The “control panel” comes up momentarily and all settings are at “0” and all the “setting boxes” are outline in red. Then the control panel “disappears”. It only on screen for about 1 second. while it’s on screen I tried to adjust the settings but that does not work. they won’t move from zero. I tried re-installing the program and the problem still exists. Did not occur in 2.4.0. Of interest is that the Upscaling still seems to run , as I see the “timer” working, and it seemingly adjusts, at some level, the photo but cannot control the settings. Thanks, Peter

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.