Upscale does not work when bringing a PSD file (that has already been sharpened and denoised) back into Topaz AI

TOPAZ AI version 3.0.3 on 2024 iMac with Sonoma 14.5

  1. sent an edited PSD from PS into Topaz AI for sharpening and denoising - worked fine.
  2. exported sharpened and denoised file back to PS
  3. tried to take sharpened and denoised PSD file from PS back into Topaz AI for upscaling and was not able to make any kind of changes at all - no typing in new dimensions, no increase by 2x etc, no modify controls - nothing could be done.

Are you using the Automate plugin? Filter menu plugins can’t alter the size of the image.

Yes using the Automate plugin seems to work correctly - thanks very much!!

it only works with TIF files I ran into the same issue today and got it resolved but the upscaling takes forever so I’m more prone to upscale it in Photoshop 2024. Maybe one day Topez will rewrite the coding to make it go faster and also my computer is as fast as it goes is loaded up-Using windows 11

I’ve used Upscale (within Photo AI) successfully with Photoshop PSD, TIFF and JPG files on a 2024 iMac. It can take a bit of time to do the upscale depending on the size of the original file, how large you are trying to make it and the speed of your computer. I have gone from 6,000 x 4,000 pixels up to 21,200 x 14,100 pixels and it has taken less than a minute to do the upscale. I’ve done the same upscale in PS and PS tends to introduce a bit of noise during the upscale that Photo AI does not. Just my experience.