Updates not complete. Administrator permissions required

Every update I have tried so far has been a major issue. I end up having to go through multiple reboots. I am running Win 10 Pro and am the administrator account. I have to reboot into safe mode to delete the Topaz Studio directory and do a reinstall.
First update I tried from inside the software. Error came back that software was already running.
Next version update (1.0.9 i think) I tried to do the update with the software not running and keep getting Administrator permissions required.
This version (1.1.5) was the same thing all over again. I end up wasting an hour plus and having to do the Safe Boot to delete the directory to get an to complete.

Is this just me? Not understanding why this has been an issue for each update.

Firstly that seems as though you have a problem with access to the program directory … seems like permissions are possibly corrupted. You have a couple of options:

  • Go to the program directory and check the permissions, it should be that if you are an administrator you have “Full Control” … note that this should be exactly the same as the permissions for SYSTEM. If not check your Admin user Id and see that you are actually the creator of the directory.
  • The other option is to raise a support request by clicking on the “Topaz Studio Help Center” link above and have support look at your PC as it seems that this is an ongoing issue for you.
1 Like