Update topaz photo ai 1.3.6 -> 1.3.7

Same problem as I reported before “Update Topaz Photo AI 1.3.2 to 1.3.3”
1.3.4, 1.3.5 and 1.3.6 updated without a problem.

Getting exactly the same issue now I update from 1.3.6 to 1.3.7
The issue is not in the 1.3.7, but the update procedure of 1.3.6

Clicking on update results in an error screen. Not even the download of the modules starts.

Workaround is to download the version from the website and install.

Topaz AI update error
Topaz Photo AI Installer Log.txt (1.5 MB)

Error on screen and log after update problem occured hereby included

Thanks for sharing this. I am speaking with my team to figure out what happened. Unfortunately the Installer Log does not show the issue.

Could you share your system profile? I need to confirm your exact Windows version number.

Please visit this page, select your operating system (Windows or Mac) and click “Find Your System Profile”. Send me the system profile so I can check your system specs.
Topaz Photo AI System Requirements

Next time you try to update using the patch, please send me the Topaz Photo AI application log from that session. It should be in the last 3 logs, and will show me the information that is missing from the Installer Log.

DxDiag.txt (118.6 KB)

Hi Lingyu,

hereby my system profile as requested. It is a (older) custom build machine on a Asus motherboard with a I7 processor.
My internet connection is a fiber 300 Mbps line.

Like I said before, it didn’t append on all versions. But when it happens there are two distinctive behaviours:

  1. Update is downloaded and error occurs in the installing phase. Like the downloaded image is corrupted.
  2. Clicking on the update knob, and nothing happens. No download of the update.

In both cases a manual download from the Topaz website is the sollution for me. Download goes fast and installing is done correctly in no time.
I haven’t have any problems with this machine to install or update any other software. And it seems to only appear when I use the “update” option in Photo AI program itself.

Thanks for sending the system profile. Do you have the log file from when you tried using the in-app updater for the latest version?

hi Lingyu,

not anymore. Last time it actually didn’t even start downloading.
But I’m outstationed at the moment, so I can’t test anything on my system.

best regards,

Johnny De Gruyter

E-mail blenchi88@gmail.com
follow me flickr JohnDG photography

Got it. Please update me if you run into the issue again and send the installer logs for the failed attempt.

Hi Lingyu,

same problem from 1.4.3 to 1.5.0

Got the “update available” on top of the screen of Photo AI. When I click it, I get the whole explaination with changes and the knob “update”.
When clicked “update”, the turning icon of Windows appears. No downloading starts (normally the bar in the left top corner would suggest download of packages".
After, not downloading anything, the Windows installer is called and you get the message “This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package”.
Of course, no logs, because the installation didn’t start.
The problem is situated in the old version, not in the new, as nothing is downloaded. The Windows Installer is called with no valid file, actually no file at all.

I’ve downloaded the version from the website and will install that one, instead of “update”.

Did this only happen with the v1.4.3 to v1.5.0 major update? Did it happen when updating from v1.4.2 to v1.4.3?

I’m curious if the patches are working for you but the major updates with full installers are not.

Hi Lingyu,

indeed it happened from 1.4.3 to 1.5.0 and not from 1.4.2 to 1.4.3.
I didn’t notice the problem for a while now, doing minor updates.

And it is situated at the moment it need to start the download of the new version. The download bar on the upper left corner doesn’t appear. So, I guess the files for the new version weren’t downloaded and can’t start the installation process.
Probably it’s about the numbering. The “old” program does expect the next number being 1.4.4 and not 1.5.0.

Just updated from 1.5.0 to 1.5.1, no problem. Download bar on the upper left popped up and installation went smoothly.
I think you’re right that it only happens with major updates, when the version numbers do not succeed each other.
Now, wondering, if you skip a version, say from 1.4.3 to 1.4.5. Would that trigger the same problem?

We release patches for every small version update, for example from v1.4.2 to v1.4.3.

Skipping a version will download the full installer I believe. I will double check with my team.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.