Update Topaz Photo AI 1.3.2 to 1.3.3

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]

Steps to reproduce issue:

  1. Clicking “update available” on version 1.3.2

  2. Update screen appears

  3. click on “update” on the bottom of that screen

  4. after some time an error screen appears. Download didn’t start

  5. Topaz photo AI abends

  6. restart Topaz Photo AI 1.3.2 and do the steps 1 to 4 over.

  7. same error message appear, no download and program abends.

  8. restart Topaz Photo AI 1.3.2 and this time the “update available” sign does not appear.

  9. I open “Account” and click on “check for updates”

  10. update screen appears and I click on “update”

  11. This time, the download on the left upper corner appears.

  12. The update dialogue starts after the download. Installing of the update starts and finishes without error.

  13. succesful installation

This time no ask to authenticate (like it sometimes did in the past)

Topaz Photo AI [v1.x.x] on [Windows/Mac]

DxDiag.txt (107.4 KB)

hereby my configuration.
It is a custom build Windows 10 pc, I build myself. Asus main pcb, 16GB memory with Nvidea Geforce GT980, Samsung SSD 860 Pro for the OS and two WDC hard drives, 1 for software and 1 dedicated for storage of my pictures.

Please open Topaz Photo AI, go to the menu bar on the top and click the Help > Open Log Folder menu option. Attach the installer log that you can see in the window that opens.

It seems like the patch is not working. Get an installer from the downloads page and you can update this way:

Hi Lingyu,
I already downloaded the 1.3.3 version and installed it from there. That was no problem. But the “update” knob in Photo AI that fails most of the time. Had it with former versions too.
It feels like the “update”-knob isn’t doing what it is supposed to do.
I include my installer log. You will see, I tried a couple of times to do the “update” from within PhotoAI, but only succeeded after downloading the installer from the webside. Afterwarts, Photo AI goes into “demo” mode and have to authorize it again. That process also need to be done a couple of times before acceptation. The first time after installing it seems to be ok, but afterwarts it becomes a “demo” version and needs to be authorised. For some reason the license is lost when installing from the download installer.

Topaz Photo AI Installer Log.txt (3.4 MB)

Thanks for sending the installer log. This one shows it was completed successfully.

I’ll look into this issue with the authentication getting lost with the update. I haven’t seen other reports of this behavior yet so I’m not sure what’s going on.

If you get a failure while updating again, please immediately send me the installer log as that will show the failure so I can figure out the cause.

Hi Lingyu,
the problem initiates from the “update” button in the Photo AI program. When that happens, I use the download from the website. No problem with that. The problem situates in the “update” procedure within in the Photo AI program, not when you install the full download from the website.
It feels like the download within the “update” button procedure gets corrupted somewhere or the download buffer wasn’t cleared entirely before starting installing.

Hi Lingyu,

just did the 1.3.4 update without a problem using the “update” button.
I surely will send you the log when an update goes wrong, before I install from the full version from the website.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.