Update Installer Hung Before Updating AI Models

I was invited to upgrade Topaz Photo AI via the ‘Updates Available’ button on the upper right corner of the Topaz AI window. I clicked, and selected install after current process finishes. Everything went swimmingly until it came time to ‘Download AI Models’. At that point the process hung and I had to Force Quit. How can I update the AI models used by V 1.3.6 and complete the installation?

Steps to reproduce issue:

I launched the updated software successfully, and tried to update the AI models using the ‘Check for Updates’ button in the software it says I have the current version ( with no reference to AI models).

Topaz Photo AI v1.3.6 on 2013 Mac Pro, 64 GB RAM, 1 TB HD, 262 GB free

Hi @michael.bade, can you try downloading a new copy of the Topaz Photo AI installer from our Topaz Labs Download Page instead?

Use this to repair your current installation, let us know if this also freezes when you try to run it.

I just downloaded Topaz Photo AI 1.3.6 again, and ran it. When the installation process reached the point of downloading the AI models, the update process froze, again. I opened Force Quit on my Mac Pro (MacOS 12.6.6) and Force Quit said Photo AI Installer Not Responding. As I was typing this message, there was a chime and the Not Responding message in Force Quit went away. I do not know if this was because the AI models loaded, or the process force quit (I did not click on anything). I will try using the program and see what happens.

@michael.bade What were the results of the test?

When you update, make sure to disable antivirus, firewall, VPN, or proxy that may be on your computer. These are known to block the installer from downloading the model files.

The results so far are on one computer (2013 Mac Pro, Monterey 12.6.6) I was able to download and install successfully, including AI model download. The process wasn’t smooth - the porcess appeared to have hung until suddenly there was a chime and the updater said everything was successfully updated. I tested the porgram on an image and it worked. I will do the same update process on my laptop tomorrow (2019 MacBook Pro, Ventura 13.4).

Were you able to get it working on the second computer?

Yes, I was. There was a software update in the middle of my efforts, and I also restarted the computer after the update. Once these were done download went smoothly.


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.