Update Downloads Slow Throughput

A fairly simple suggestion that I think would improve the perception of the Company a great deal. I have been using Topaz for many years and enjoyed the process we have gone through, upgrading to the current versions and abilities.
However, there is one thing that appears to have taken retrograde steps rather than upgrade. That is the speed of your servers.
My internet connection is I believe average these days I have a 75Mb download capacity and a 32Mb upload facility. Why then does Topaz deliver the updates at speeds that date back to dial-up connections i.e.800-900KB/s LESS THAN 1Mb
Updating is a painful process that takes me over 40min per software. When each download is only just over 1Gb
I think you need to update your servers before the next software update - please!

You should check with your ISP as that seems to be their issue as 75 Mbps delivers approximately 8.94 MB/second. So each 250 MB download would take about 30 seconds.

I suspect you are on ADSL which would have slow speeds because of others sharing the line. For example I have a 300MB/1GB fiber connection and a download of Topaz products as a full installer takes less than 2 minutes and as an online installer no more than 4 minutes.

Actually that’s not the case. My connection is Fibre to the box and copper to the house (approx 200m). So unfortunately its not the ISP. All other connections I make utilise most of the speed/bandwidth available to me. The only other variable is the Topaz servers.
For example I also use Adobe software and a 2.4Gb supply from them last evening took less than 5 minutes.

I updated Sharpen-AI this evening and it took just a few minutes (100/100 Mb fiber).

I have never had a Topaz update take anywhere near 40 mins.

1 Like

Unfortunately, it is ONLY Topaz I have this problem with so there must be some odd connection with the issue somehow?


I don’t have this issue with any other connection I try. I actually did contact my supplier and they have tested the line, they get good connections all the way to the house. I have tested on my computer and the dropoff from the street to the computer is almost undetectable i.e. the difference between their readings and mine is less than 10kbs (not worth noting). As I mentioned before I updated Adobe yesterday and that was a 2.4Gb download which took less than 5 minutes. The problem is definitely something occurring between me and Topaz…!

You shouldn’t have any issue as the host is Amazon Cloud AWS. Try testing your speed using something like speedtest and connect to a server in say Singapore.

Amazon has a distributed Cloud so you could be connecting anywhere in the world.

With the greatest respect this was first of all a polite statement, not necessarily a criticism. However the comments I have received have all been slanted to a problem my end.
I am very, very well aware of the way things work. Part of my income comes from working in the sector. However, I have followed all the suggestions that have been thrown my way so far and all the answers, without exception, have pointed to something awry elsewhere than at my end.
To keep all things going in the fairness arena and as equal as possible in comparison, I have now used the same speed test provider and done two tests within minutes of each other using both a local server and a server actually in Singapore as suggested. Here are the results…

1 Like

As my background is telecoms I always look at the local throughput to eliminate that. In your case it seems to be pretty much the same across the world for you.

Singapore was suggested because AWS is also there. The next option for you is to contact support at the main Topaz Labs website to see if they can help.

Further than that I don’t have any other suggestions because I don’t experience the issues you have.

Do you have access to a Linux host where you could run traceroute? ie to see the network path you are traversing from end-end? With the distributed nature of AWS it is possible that the issue is somewhere “in the middle” and not necessarily at either end.

If you are using a VPN then your download speed may be reduced. I’m in the USA and my rated speed is 275Mb/s and when updating a Topaz file I get about 27MB/s (x8=216 Mb/s) but if I’m connected through my VPN it drops to about half that speed. So Topaz Servers are fast. There may be something between their servers and you that is slowing things down. You don’t really say where you are located.

Sorry of course I should’ve said. I’m located in the UK, being provided my service by a 3rd party i.e. not the line provider but another using the same lines that everyone else does (they just vary the price to get the business). I’m not using a VPN but certain suppliers do ‘cap’ the speed they provide in order to capitalise on peak and slack times. My stated supply by my ISP is 79Mb/s and is (as they say) unlimited. As you can see from the screenshots from earlier I don’t suffer too much considering it was tested over different worldwide servers.
I updated an Adobe item the night after the last Topaz update which was nearly twice the size of the Topaz set of files, and that took less than 5mins compared to the Topaz update that took nearly 40mins.
It is ONLY Topaz that seems to have the problem and that is a puzzle. I have requested a look into it by Topaz support and we’ll see what comes of that.

1 Like

Which install method did you use? ie embedded updater or d/l of full pkg? I apologize, but I don’t recognize this for certain from the Mac screen-shot (I think?).

If you download a large pkg directly from the web-site (assuming that’s not what you already did) do you observe the same slow speeds?

If I had to guess, I’d say something odd is going on with AWS in your locale, but I’m not sure the best way to trouble-shoot unless you have an AWS account (which you probably don’t).

I have always used the reminder you get in the software when launched which says an update is available, do you want to install? This then downloads an online installer which when run gives the info you see in the screenshot from earlier.
So I thought I’d try direct from the Topaz site. But all this does is the same thing. Selecting ‘download’ just downloads the same online installer as before. So I uninstalled Gigapixel as a trial (it wouldn’t overwrite the existing installation) and just started a fresh install from the downloaded installer. Unfortunately no difference…

eg I was thinking in terms of this, but the installer options may have changed and I’m not sure if you still get a choice. Don should know.

As a test, you might ask support to point you to some link to a large file on the same servers to do just a vanilla download and observe the throughput to see if it differs significantly from what you see in your update procedure. I don’t know why it would, but it might be good to rule that out.

Topaz-installer

If you download full installer here do you observe the same slow speeds?

Sharpen downloads

Unfortunately I don’t get those options…


I have a ticket open with support. Maybe when they respond I can try that route.

They are available from the Product Release threads on this forum and from the download page on the main website …

When you click on the link I supplied you don’t?

Sorry, didn’t realise it was actually a link (didn’t click on it). That link you supplied downloaded at a normal pace…! i.e. took less than 2min. My connection with the main website (as per the screenshot you showed) just downloads the online installer.

Hi,
just to let you know: Same situation here (in Germany).
Trying to download an update für Gigapixel takes an eternity, download rate being a mere 250kByte per second. This had already happened a while ago, but was gone a day or two later. Now it seems to persist. A couple of days ago with a different Topaz Program everything worked fine.

And no, it is not an ISP, cable or other network issue. I just downloaded two Adobe updates at the usual speed > 80 MBt/sec. Before and after that Topaz was slow.