Update 1.3.1 making Groundhog Day

While running update it runs as usually but after installation and opening the app it still says update available (1.3.1), letting it run and same thing happens again, again, again…

What OS are you on … In future please provide the basics for trying to rectify a problem.

Note: if you are already on 1.3.1 it will say on the banner, and the update will say what it is trying to update to. If it is 1.3.1 … don’t bother.

Win10 64bit, banner 1.3.0

Try updating to 1.3.1 by downloading the full installer from the release thread and installing after you uninstall 1.3.0, note when you are installing make sure all hosts such as PS, LR etc., etc. are closed …

If the update doesn’t work please add a DxDiag report to this thread,

Hi @Jari1966, were you able to get your app updated?

Hi Preston,

By downloading 1.3.2 from download section it worked alright, via update-button not.


Lähetetty iPadista

Got it! If you find that you run into the same error today after we release the next Topaz Photo AI update, please submit a support ticket at support.topazlabs.com so our Topaz Photo AI specialist can track this and get back to you ASAP :slight_smile:

Hi Preston!

Same thing with 1.3.3; updating keeps asking/telling again, again to
update etc.

So I signed in and downloaded it from my account and going to instal it
after this message.

Best wishes

Jari Juntunen

Preston Werner via Topaz Community kirjoitti 4.5.2023 22:33:


Sorry to hear that! Please visit support.topazlabs.com and click this support beacon at the bottom of the page;

This will open up a prompt for you to email our Topaz Photo AI specialist directly – this is something we’ll want to keep track of through that method of contact :slight_smile: