Unable to start TS 2x, AI mask

After numerous months and discussions with Topaz support and developers I am still unable to run these products. They install but do not run. No error messages, task manager show active background processes. Older versions of TS worked fine.
The common thread is the new installer they changed to.
If anyone has any suggestions that would be great.

Please provide details of the PC you are running it on and the type of User permissions your UID has.

PC details should include CPU, RAM, OS version (actual version using winver), and installed GPUs, vRAM and driver versions.

Also, if it is a commercially available PC, the make and model please.

Then I want you to do the following …

Open the registry editor by typing the following in the search box:


Select the application and run it.

Then type the following into the search box under the menu and press enter:

Computer\HKEY_CURRENT_USER\Software\Topaz Labs LLC

Then click the “>” next to the entry and you should see this depending on the applications installed:


Click on the Topaz Studio 2 entry and take a screenshot and post it here please.

I have a ACER Predator 17. About 1.5 years old.My OS is Win 10 home (latest with all updates) and 16 gig RAM, My GPU is NVDIA GTX 1060 Diver version dated 04 Sept 2019 and has 16 gig dedicated video RAM. All OS and drivers and MS Visual basic products etc are up to date (as per Topaz tech support validation).

I’ll provide the other info from you email in the other post.

Your NVIDIA driver is well out of date - I have the GTX 1060 and my driver is 442.92 released on 16 April 2020. You’ll need to download the updated one from the NVIDIA website.

Thanks Paul.
I think my drivers were only a few months out of date I had 445,75 and the latest for my notebook was 445.87 so i did upgrade them as per your suggestion and I still have the same issue.

Hi Don,
Screenshot below.

As an aside, TS2 and AI Mask run fine on my wife’s machine and I did compare registry entries with hers and they are the same. However I did note that if I look at the Windows Control Panel, Program and Features when you observer the program icons next to their respective programs the icon (for the programs that do not run) is not representative of the program. I think this implies that it did not install correctly. See below.

I think I may have mentioned that TS 2.2.0 ran fine and then when I upgraded to 2.3.0 it removed the old version and tried to install (run) the new one. I think this is when Topaz may have changed their Installer. Then I tried to install AIMask and the same thing happened i.e. installed but does not run.

In both cases (TS and Mask) the programs run through the installation with no error messages. When I run them they show up on as a background process (in Task Manager) but not as an Application running. Please see below.

Background Process


I did notice one thing after a suggestions from Topaz Labs. They had suggested that I look for the folder Topaz Labs LLC in the C:\Users\Peter Laptop\ AppData\Local directory.

When I went there, there is no folder named Topaz Labs LLC either when I have installed the apps or even after I have removed them and reinstalled them. However on my wife’s machine (i.e. the one that works with the programs) there is indeed a Topaz Labs LLC folder with the respective folders within it (i.e. TS, Mask and Sharpen).

Is it possible that there is something preventing the Topaz Labs LLC folder from being created on my machine in the C:\Users\Peter Laptop\ AppData\Local\ folder?

I then:

  1. Uninstalled AIMask
  2. Manually created the Topaz Labs LLC folder in the C:\Users\Peter Laptop\ AppData\Local folder
  3. Reinstalled AIMask and TS
  4. Looked in the Topaz Labs LLC folder and there were no subfolders there.
  5. Ran programs and the same issue persists.
  6. Uninstalled both programs and deleted the Topaz Labs LLC folder
  7. On the working machine (wifey’s) there is indeed a C:\Users\Joan New Laptop\ AppData\Local folder containing the Topaz Labs LLC folder and three subfolders i.e Topaz Studio, AIMask and Sharpen.

I am awaiting a response from them.

In your registry I see an entry for Topaz Studio 2 BETA, please check in your apps under settings and see if you have Topaz Studio 2 BETA installed. If so uninstall it and delete any folders on you HD in Programs and ProgramData under the Topaz Labs LLC folders, then in the Local Application Data. Then delete the upper level registry entry. I’m not sure why you have had the BETA installed?

The next thing you can do is check under the Topaz Labs entry in the registry by using the arrow to expand it, just above Topaz Labs LLC entry, and just post a screenshot of the contents.

And then please go to %localappdata%, just type that including the % signs at either end, in the explorer search bar and press enter. There should be a Topaz Labs LLC folder there and a entry for Topaz Studio 2 and Mask AI. If not then the installer doesn’t have the necessary permissions to creat support directories.

If that is so you will need to use a Admin user id to install and install for all users to see if that makes a difference.

Hi Don,

  1. I have deleted the TS2 Beta - have no idea why it was there since I never downloaded the Beta version. Also it did not show up in my Windows App Programs.
  2. There was not a Topaz Labs LLC folder under the Local Application Data folder so I could not delete it.
  3. Here is the screenshot of the registry entry (local machine)
  4. Here is the screenshot of the registry entry (Current User)
  5. In the %localappdata% folder there is NOT a Topaz Labs LLC folder. Point of interest, in comparing it to my wife’s machine there is that LLC folder.
  6. I repeatedly installed the programs with the “run as administrator” setting and in fact my Windows account has admin privilidges.

I tend to agree with you that the folders do not seem to be installing at the right location (if at all). Again the major differences in comparing my wife’s working machine is that the LLC folders are not being created on my machine. I have checked permissions on a number of folders (unless I missed one) and they all have "full control"etc. I have used the same install program from Topaz on both machines.

I am concluding that somewhere on my machine the permissions are incorrectly set. By the way I also have tried installing with my Norton Anti Virus and Firewall disabled. Same issue.


Further info.
It appears that the install on my machine does not create the folder Topaz Labs LLC. I have checked all the permissions on the necessary folders and they are the same as on the good machine.
Is there somewhere else I should check that might be preventing the install on the good machine from creating this folder?.
As an aside I did copy the Topaz Labs LLC folder (and sub folders) over from the good machine to the bad machine, rebooted and it did not make a difference. I then subsequently deleted to copied over folders to put it back on the original state.


Ok, firstly the UiD you use to install must be an Administrator Id and you need the following access to LocalAppData at the highest level for the SYSTEM, the UserID used for install and for Administrators on the PC:


Then check in your AntiVirus that it hasn’t blocked access to the AppData folders.

All I can say is that at install time your simply don’t have the necessary permissions for the UserID you are using to run the application because it needs to create a set of QML cache files in the LocalAppData folder.

I haven’t read back through your posts but have to tried right-clicking in the icon and choosing Run as administrator?

Also please check that the Install Folder and the .EXE’s for both applications have the following entries under security:


If it doesn’t add the authenticated user by going to the Security panel for Topaz Labs LLC, click on Edit the in the search box type in Authen, select the Authenticated Users entry and allow all permissions except Full control and Special permissions.

Have you checked whether Windows 10’s Controlled Folder Access is enabled. If so try disabling it.

I use Norton Internet Security and Anti Virus. I have tried the install with all of Norton disabled. Same issue.
When I go to try and find the WIN 10 Controlled folders through Settings etc… it is not there. I believe this is because I am using a third party app for Security. So I cannot see if the Controlled folder option is on or off.

  1. My User ID had Admin privileges.
  2. The LocalAppData folder has the highest level as per your picture.
  3. Have disabled AntiVirus and reinstalled - same issue.
  4. Have ran the install as an Admin. - same issue.
  5. The Install folder and the .exe’s were missing the Authenticated User entry. Added them, rebooted machine - same issue.

I totally agree that is is a permissions issue and can confirm that the Topaz Labs LLC folder is not created by the Install.

I did copy over the Topaz Labs LLC folder with the Topaz Studio 2 sub-folder from my wife’s working machine over to my machine so that the qml, cache files etc would be present. Rebooted - same issue.

Topaz (Emily) suggests performing a Registry Clean (I have CC CLeaner) but I am nervous about doing that in case it messes up something else (even though it creates a backup registry). She also suggest I contact Windows Support. Not sure how fruitful that would be.

I’ll keep looking for the culptrit.

1 Like

Took the plunge and used CC Cleaner (registry cleaner). Rebooted, reinstalled - same issue.